Search all messages leads to no result and tab freezes. Afterwards search function is blocked.

RESOLVED WORKSFORME

Status

Thunderbird
Search
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Bluelightav.org, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gs], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9pre) Gecko/20100217 Lightning/1.0b1 Shredder/3.0.3pre 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9pre) Gecko/20100217 Lightning/1.0b1 Shredder/3.0.3pre 

When I had 4 email pop accounts the search all messages worked always fine. I turned 2 accounts into imap and shifted the email into imap folders. All that worked fine. But now when I use "search all messages" with simple keywords (example Tally, test, funding) the search engine gets stuck with the search tab open. See screen shot. 

Reproducible: Always

Steps to Reproduce:
1. enter keyword test into "search all messages"
2. new tab opens with search results and gets stuck

Actual Results:  
new tab opens with search results and gets stuck


Expected Results:  
search results are shown

I observed that this issue only appeared after configuring imap accounts
(Reporter)

Comment 1

8 years ago
Created attachment 432411 [details]
tab opened while searching gets stuck
(Reporter)

Comment 2

8 years ago
When I search for the following key word: follow up

When I enter follow up -- search engine hangs
When I enter "follow up" -- search engine works
When I enter follow -- search engine hangs
(Reporter)

Comment 3

8 years ago
When I enter "follow" -- search engine hangs

I observe this behaviour with many keywords
Anything in Tools -> Error console ?
(Reporter)

Comment 5

8 years ago
Thx for the clue :-)

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.server]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/lib/thunderbird-3.0.3pre/modules/gloda/datamodel.js :: anonymous :: line 475"  data: no]
Source File: file:///usr/lib/thunderbird-3.0.3pre/modules/gloda/datastore.js
Line: 415
2010-03-22 20:51:01	gloda.ds.qfq	ERROR	Exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.server]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/lib/thunderbird-3.0.3pre/modules/gloda/datamodel.js :: anonymous :: line 475"  data: no]

Comment 6

8 years ago
asuth, see comment 5. The Duke mentions same error and line number for datamodel.js in http://gsfn.us/t/nsxs
Whiteboard: [gs]
It would appear that the query is returning a message that belongs to a folder that no longer exists.

Reporter, when you say that you turned accounts into IMAP, I am assuming you did not directly manipulate the prefs settings or otherwise perform some scary transformation, but rather added new IMAP accounts and deleted the old POP accounts?

Did you ever disable the "global search and indexer" mechanism?  It's possible things got inconsistent if you made changes while it was disabled.

The most likely explanation is that gloda throws various exceptions when accounts are deleted and thus fails to purge a lot of stuff from its database and this leads to corruption.  We literally have no test coverage of that situation.
(Reporter)

Comment 8

8 years ago
I created new accounts and folders and moved emails over via right click. In those accounts are no even lots of mails. A few hundred at most. 
I never disabled the indexer. One of the outstanding new featurers for me is the better imap support and the search function.
(Reporter)

Comment 9

8 years ago
This bug is still not fixed in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100423 Lightning/1.0b1 Thunderbird/3.0.4 ThunderBrowse/3.2.8.1
on Lucid 32 bit

When I type the word meeting in the search engine is starts to search and hangs. Here the error output:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.server]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/lib/thunderbird-3.0.4/modules/gloda/datamodel.js :: anonymous :: line 475"  data: no]
Source File: file:///usr/lib/thunderbird-3.0.4/modules/gloda/datastore.js
Line: 415

2010-06-06 09:25:42	gloda.ds.qfq	ERROR	Exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.server]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/lib/thunderbird-3.0.4/modules/gloda/datamodel.js :: anonymous :: line 475"  data: no]
(Reporter)

Updated

8 years ago
Severity: major → critical
Can you try 3.1RC2 ?

Comment 11

7 years ago
I still have the same problem with 3.1

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.server]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/modules/gloda/datamodel.js :: anonymous :: line 475"  data: no]
(Reporter)

Comment 12

7 years ago
For me in 3.1.6 this error doesn't appear any more.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101027 Lightning/1.0b2 Thunderbird/3.1.6 ThunderBrowse/3.3.2

Comment 13

7 years ago
WFM per reporter. Thanks bluelightav for updating the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 14

7 years ago
Unless Asuth wants this bug to cover the following condition?? ..

Asuth in comment #7
> It would appear that the query is returning a message that belongs to a folder
> that no longer exists.
> ...
> The most likely explanation is that gloda throws various exceptions when
> accounts are deleted and thus fails to purge a lot of stuff from its database
> and this leads to corruption.  We literally have no test coverage of that
> situation.
No need to use this bug to track that.  Certainly if we start seeing tons of problems exactly like this, we should morph one of them or make sure we create the appropriate dependent bug.  Right now I expect that to be addressed as part of UI development whenever we fancy up the account dialog.

Comment 16

7 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101218 Lightning/1.0b2 Thunderbird/3.1.7 ThunderBrowse/3.3.4

I have not experienced this problem recently.
You need to log in before you can comment on or make changes to this bug.