add getElementsByAttribute to any Element node not just XulElement nodes

RESOLVED WONTFIX

Status

()

Core
DOM
--
enhancement
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: Georg Maaß, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.9pre) Gecko/20100313 SeaMonkey/2.0.4pre
Build Identifier: 

On XulElement nodes there is a very useful method called getElementsByAttribute, which I would like to use on any Element node independent of whether being member of a XUL document or not.

If I parse xml files using XMLSerializer I would like to have this method on any Element, because I very often search for elements identified by attributes.

Reproducible: Always
You can already use document.querySelectorAll('[attr="value"]') and document.querySelectorAll('[attr]'). We really shouldn't expose proprietary extensions if there is a standardized alternative.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.