tarball version Jetpack SDK 0.1 with permission problems in MACOSX FS

RESOLVED INCOMPLETE

Status

Add-on SDK
General
RESOLVED INCOMPLETE
8 years ago
8 years ago

People

(Reporter: RoDrigo Garcia S., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 0.1

I downloaded the 0.1 tarball Jetpack SDK version and looks like this package has some rights issues with the filesystem in MacOSX (10.6.2). Starting a @Longlink file appears, witch contains this hard route:
jetpack-sdk-0.1/packages/jetpack-core/tests/interoperablejs-read-only/compliance/absolute/submodule/a.js
I tried to change the permission, but didn't works. I got the version from the mercurial repository and also the zip version and works well. 

Reproducible: Always

Steps to Reproduce:
1. Get the tarball version in the Jetpack website
2. Extract it
3. Run source/activate
4. Run cfx testall
Actual Results:  
The exception I wrote in:
http://paste.ideaslabs.com/show/GwIGTG00LB

Expected Results:  
The FS permissions fixed it
(Reporter)

Updated

8 years ago
Version: unspecified → 0.1
I wonder if this is related to a problematic test that we commented out because it was causing incorrect test failures on Windows.  I just tried to reproduce this on Mac OS X 10.6.3 with Jetpack SDK 0.2, and I was unable to do so.  RoDrigo: can you still reproduce?
old bug, no feedback from reporter -> RESOLVED INCOMPLETE.

if you're still seeing the problem, please re-open the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: 0.1 → unspecified
You need to log in before you can comment on or make changes to this bug.