If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

A lot of errors are thrown when an Atom feed queries Bugzilla

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
Query/Bug List
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Frédéric Buclin, Assigned: Frédéric Buclin)

Tracking

({regression})

3.4.6
Bugzilla 3.4
regression
Bug Flags:
approval +
approval3.6 +
blocking3.6 +
approval3.4 +
blocking3.4.7 +

Details

Attachments

(1 attachment)

876 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Assignee)

Description

8 years ago
Created attachment 432470 [details] [diff] [review]
patch, v1

Since Bugzilla 3.4, every time an Atom feed queries Bugzilla, you get tons of:

buglist.cgi: Argument "2009-03-10 16:17:18" isn't numeric in numeric comparison (<=>) at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Template/VMethods.pm line 493.

That's due to this line in list/list.atom.tmpl, line 39:

  <updated>[% bugs.nsort('changedtime').last.changedtime FILTER time("%Y-%m-%dT%H:%M:%SZ", "UTC")
    FILTER xml %]</updated>

changedtime (aka delta_ts) is not a number and so TT complains. This is a regression due to bug 399070, where changedtime was no longer converted to a number. Due to the formatting of dates, this conversion is not needed and a simple string-comparison is enough.
Flags: blocking3.6+
Flags: blocking3.4.7+
Attachment #432470 - Flags: review?(mkanat)

Updated

8 years ago
Attachment #432470 - Flags: review?(mkanat) → review+

Comment 1

8 years ago
Comment on attachment 432470 [details] [diff] [review]
patch, v1

Oh wow, THAT'S where those warnings come from! Yes, we should definitely check this in ASAP! :-)

Updated

8 years ago
Flags: approval3.6+
Flags: approval3.4+
Flags: approval+
(Assignee)

Comment 2

8 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/list/list.atom.tmpl
Committed revision 7067.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified template/en/default/list/list.atom.tmpl
Committed revision 7036.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.4/
modified template/en/default/list/list.atom.tmpl
Committed revision 6748.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.