XPI package containing filenames with accented characters will fail on installation

RESOLVED DUPLICATE of bug 296795

Status

Core Graveyard
Installer: XPInstall Engine
--
minor
RESOLVED DUPLICATE of bug 296795
8 years ago
2 years ago

People

(Reporter: Laeb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2pre) Gecko/20100302 Lanikai/3.1b1

In an xpi package with the following structure:
/install.rdf
/chrome.manifest
/chrome/mytextension.jar
/chrome/library

If library folder contains for example touché.gif file, installation will fail with safeInstallOperation: file extraction failed, rolling back file moves and aborting installation.

Reproducible: Always

Steps to Reproduce:
1. Create an xpi package with the following structure:
/install.rdf
/chrome.manifest
/chrome/mytextension.jar
/chrome/library

2. Add a touché.gif file in library folder.

3. Try installing the xpi.
Actual Results:  
Installation will fail with the following error message in extensions.log: safeInstallOperation: file extraction failed, rolling back file moves and aborting installation.

Expected Results:  
Installation is completed.
Component: General → Installer: XPInstall Engine
Product: Thunderbird → Core
QA Contact: general → xpi-engine
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 296795
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.