"Memory" directory is compiling twice while building fennec

RESOLVED FIXED in mozilla1.9.3a4

Status

defect
RESOLVED FIXED
9 years ago
Last year

People

(Reporter: starkov.egor, Assigned: starkov.egor)

Tracking

Trunk
mozilla1.9.3a4
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091214 Firefox/3.5
Build Identifier: 

When compiling fennec "memory" directory is copied into to build directories "fennec" and xulrunner and compiled also twice. "memory" should be compiled only once in xulrunner and excluded from fennec build.

Reproducible: Always

Steps to Reproduce:
Build mobile according to https://wiki.mozilla.org/Mobile/Build/Fennec
Actual Results:  
"memory" directory not existing and not compiling in mobilebase/fennec

Expected Results:  
"memory" directory exists and compiling in mobilebase/fennec
Assignee

Comment 1

9 years ago
Attachment #432516 - Flags: review?(ted.mielczarek)
Also there are no any reason to compile libmozalloc when we are compiling against LIBXUL_SDK, and because LIBXUL_SDK is providing shared libmozalloc library
Assignee: nobody → starkov.egor
Component: XPCOM → Build Config
QA Contact: xpcom → build-config
Comment on attachment 432516 [details] [diff] [review]
exclude memory from fennec build

Ok, makes sense.
Attachment #432516 - Flags: review?(ted.mielczarek) → review+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: checkin-needed
Pushed in:
http://hg.mozilla.org/mozilla-central/rev/d46f1771de59
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.3a4
Version: unspecified → Trunk
Comment on attachment 432516 [details] [diff] [review]
exclude memory from fennec build

>-if [ "$MOZ_MEMORY" ]; then
>+if [ "$MOZ_MEMORY" -a "$LIBXUL_SDK" -eq ""]; then
Although this works in bash, it's not legal POSIX syntax because you are missing a space before the ].
Depends on: 554583
(In reply to comment #5)
>(From update of attachment 432516 [details] [diff] [review])
>>-if [ "$MOZ_MEMORY" ]; then
>>+if [ "$MOZ_MEMORY" -a "$LIBXUL_SDK" -eq ""]; then
>Although this works in bash, it's not legal POSIX syntax because you are
>missing a space before the ].
This was incidentally fixed by bug 554583.
Blocks: 555354

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.