Add-on recommendations ignores Thunderbird's version

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Administration
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: Eric Moore, Assigned: rebron)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100314 Lanikai/3.1b2pre

I'm using 20100314 Lanikai/3.1b2pre under Vista. Tools -> add-ons -> themes -> get themes launched Firefox and listed the Aero Thunderbird (supports 1.5 – 2.0.0.*) and Walnut for Thunderbird (2.0 – 3.2a1pre) themes. Aero doesn't support the required version but I tried to install both themes. Each refuses to install, claiming its incompatible with this version of Lankai.

When I do the same thing for extensions it recommends ThunderBrowse (though the web page says its not available), Adblock Plus, Zindus (2.0b2 – 3.0.*), Enigmail (3.0pre – 3.0.*) and ImageZoom (2.0 – 3.0.*).

Out of the entire list of recommended themes and extensions only one (Ad Block Plus) was installable. However the list of recommendations is chosen it should sanity check that they are actually installable before displaying them. 

The second time I did this the web site didn't say ThunderBrowse was unavailable and it replaced ImageZoom with FoxyTunes (1.5 – 3.0.*)


Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Component: General → Add-ons Manager
Product: Thunderbird → Toolkit
QA Contact: general → add-ons.manager
Component: Add-ons Manager → Public Pages
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → web-ui
Version: Trunk → unspecified
The featured list of Thunderbird add-ons is maintained by the Thunderbird team. If someone from TB wants to review the list of featured add-ons and make sure they are compatible with the latest versions, that would be welcome. (And I can give them access to update the lists themselves.)

Please comment if someone intends to do this, otherwise we'll close this bug as the AMO team only curates featured Firefox add-ons.
Component: Public Pages → Administration
QA Contact: web-ui → administration
Target Milestone: --- → Q4 2010
(Assignee)

Comment 2

8 years ago
Over to me.  Justin, can you get me access.
Assignee: nobody → rebron
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(In reply to comment #2)
> Over to me.  Justin, can you get me access.

Done. Log out and back into AMO and the Feature Manager and Category Feature Manager are in Admin Tools. Make sure you select Thunderbird as the application when updating these. Unless you only want a feature to show up in a specific locale, choose Unspecified for the locale.
Target Milestone: Q4 2010 → ---
Thanks for filing this.  In an effort to not drown in existing reports we're aggressively closing old enhancements and bugs to get the buglist to a reasonable level so we can scope and process bug sprints in an effective manner.

Patches for this bug are still welcome.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.