I have to terminate Firefox if the page contains endless alert script, because I can't stop it.

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: tr0nd0wn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100207 Namoroka/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100207 Namoroka/3.6

This bug has been filed for some prior versions, but still not fixed. There are some bad pages, that contain <script>while(true){alert('whatever');}</script>. If I open such a page, I can't close the browser because of endless alerts, so I have to terminate it, using console, losing all the opened pages and the data, I have typed in the forms, dropping sessions, etc. I think in every alert there must be an option to stop the JavaScript on the page, so user can quit the endless loop. I think it must be fixed in next version, because it's very easy to distrupt normal user's work because of that.

Reproducible: Always

Steps to Reproduce:
1. Open Notepad
2. Write "<html><head><script>while(true){alert('OMG');}</script></head><html>"
3. Save it as html page
4. Open it
Actual Results:  
I can't close the browser, and I must terminate it, losing everything I opened, written, etc.

Expected Results:  
There should be a button or checkbox "Prevent this page from opening additional windows" or "Stop JavaScript on this page", so I can quit alert loop.

I know, I post the duplicate, but this bug has been posted for many prior versions, but still not fixed.
where is the duplicate?
>I know, I post the duplicate, but this bug has been posted for many prior
>versions, but still not fixed.

Do not post duplicate bugs, It doesn't help to fix it and it only waste our time.
marking invalid, search yourself if you want to know the original bug number.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.