Tinderbox orange: Crash [@ libnptest.so!NPP_Destroy] and [@ libnptest.so!NPP_New] after running mochitests in modules/plugin/test/

RESOLVED DUPLICATE of bug 539823

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 539823
9 years ago
7 years ago

People

(Reporter: mats, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Tinderbox orange: Crash [@ libnptest.so!NPP_Destroy] and [@ libnptest.so!NPP_New] after running mochitests in modules/plugin/test/

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268682010.1268683836.16754.gz&fulltext=1#err4
Linux mozilla-central opt test mochitest-other on 2010/03/15 12:40:10

 0  libnptest.so!NPP_Destroy [nptest.cpp:540a1651c059 : 96 + 0x0]
    eip = 0x00a60b2c   esp = 0xb7f0ac40   ebp = 0xb7f0ac68   ebx = 0x00a645a8
    esi = 0x00000000   edi = 0x08290708   eax = 0x00000012   ecx = 0x00a21ac8
    edx = 0x00a23bbc   efl = 0x00210286
    Found by: given as instruction pointer in context
 1  libxul.so!mozilla::plugins::PluginInstanceChild::AnswerNPP_Destroy(short*) [PluginModuleChild.h:540a1651c059 : 259 + 0x10]
    eip = 0x018e31a6   esp = 0xb7f0ac70   ebp = 0xb7f0aca8
    Found by: previous frame's frame pointer
 2  libxul.so!mozilla::plugins::PPluginInstanceChild::OnCallReceived(IPC::Message const&, IPC::Message*&) [PPluginInstanceChild.cpp : 1231 + 0x6]
    eip = 0x0191664e   esp = 0xb7f0acb0   ebp = 0xb7f0ae78
    Found by: previous frame's frame pointer
 3  libxul.so!mozilla::plugins::PPluginModuleChild::OnCallReceived(IPC::Message const&, IPC::Message*&) [PPluginModuleChild.cpp : 460 + 0xc]
    eip = 0x019144b0   esp = 0xb7f0ae80   ebp = 0xb7f0aef8
    Found by: previous frame's frame pointer
 4  libxul.so!mozilla::ipc::RPCChannel::DispatchIncall(IPC::Message const&) [RPCChannel.cpp:540a1651c059 : 461 + 0xd]
    eip = 0x018f20bb   esp = 0xb7f0af00   ebp = 0xb7f0af38
    Found by: previous frame's frame pointer
 5  libxul.so!mozilla::ipc::RPCChannel::OnMaybeDequeueOne() [RPCChannel.cpp:540a1651c059 : 389 + 0x9]
    eip = 0x018f27de   esp = 0xb7f0af40   ebp = 0xb7f0af88
    Found by: previous frame's frame pointer
 6  libxul.so!RunnableMethod<mozilla::ipc::RPCChannel, void (mozilla::ipc::RPCChannel::*)(), Tuple0>::Run() [tuple.h:540a1651c059 : 383 + 0xd]
    eip = 0x018f355d   esp = 0xb7f0af90   ebp = 0xb7f0afa8
    Found by: previous frame's frame pointer
 7  libxul.so!mozilla::ipc::RPCChannel::DequeueTask::Run() [RPCChannel.h : 376 + 0xd]
    eip = 0x018f34b2   esp = 0xb7f0afb0   ebp = 0xb7f0afc8
    Found by: previous frame's frame pointer
 8  libxul.so!MessageLoop::RunTask(Task*) [message_loop.cc:540a1651c059 : 336 + 0x7]
    eip = 0x0199ff51   esp = 0xb7f0afd0   ebp = 0xb7f0aff8
    Found by: previous frame's frame pointer
 9  libxul.so!MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) [message_loop.cc:540a1651c059 : 344 + 0x9]
    eip = 0x019a03e5   esp = 0xb7f0b000   ebp = 0xb7f0b018
    Found by: previous frame's frame pointer
10  libxul.so!MessageLoop::DoWork() [message_loop.cc:540a1651c059 : 444 + 0xc]
    eip = 0x019a06e4   esp = 0xb7f0b020   ebp = 0xb7f0b068
    Found by: previous frame's frame pointer
11  libxul.so!base::MessagePumpForUI::HandleDispatch() [message_pump_glib.cc:540a1651c059 : 264 + 0xa]
    eip = 0x019cac40   esp = 0xb7f0b070   ebp = 0xb7f0b088
    Found by: previous frame's frame pointer
12  libxul.so!(anonymous namespace)::WorkSourceDispatch(_GSource*, int (*)(void*), void*) [message_pump_glib.cc:540a1651c059 : 109 + 0x7]
    eip = 0x019cac8a   esp = 0xb7f0b090   ebp = 0xb7f0b0a8
    Found by: previous frame's frame pointer
13  libglib-2.0.so.0.1200.3 + 0x2b271
    eip = 0x00cab272   esp = 0xb7f0b0b0   ebp = 0xb7f0b108
    Found by: previous frame's frame pointer
14  libglib-2.0.so.0.1200.3 + 0x2e24e
    eip = 0x00cae24f   esp = 0xb7f0b110   ebp = 0xb7f0b168
    Found by: previous frame's frame pointer
15  libglib-2.0.so.0.1200.3 + 0x2e7b4
    eip = 0x00cae7b5   esp = 0xb7f0b170   ebp = 0xb7f0b188
    Found by: previous frame's frame pointer
16  libxul.so!base::MessagePumpForUI::RunWithDispatcher(base::MessagePump::Delegate*, base::MessagePumpForUI::Dispatcher*) [message_pump_glib.cc:540a1651c059 : 195 + 0x12]
    eip = 0x019cb1fc   esp = 0xb7f0b190   ebp = 0xb7f0b1e8
    Found by: previous frame's frame pointer
17  libxul.so!base::MessagePumpForUI::Run(base::MessagePump::Delegate*) [message_pump_glib.h:540a1651c059 : 59 + 0xd]
    eip = 0x019cb6d4   esp = 0xb7f0b1f0   ebp = 0xb7f0b208
    Found by: previous frame's frame pointer
18  libxul.so!MessageLoop::RunInternal() [message_loop.cc:540a1651c059 : 216 + 0x8]
    eip = 0x019a0146   esp = 0xb7f0b210   ebp = 0xb7f0b228
    Found by: previous frame's frame pointer
19  libxul.so!MessageLoop::RunHandler() [message_loop.cc:540a1651c059 : 199 + 0x7]
    eip = 0x019a016a   esp = 0xb7f0b230   ebp = 0xb7f0b248
    Found by: previous frame's frame pointer
20  libxul.so!MessageLoop::Run() [message_loop.cc:540a1651c059 : 173 + 0x7]
    eip = 0x019a01e1   esp = 0xb7f0b250   ebp = 0xb7f0b288
    Found by: previous frame's frame pointer
21  libxul.so!base::Thread::ThreadMain() [thread.cc:540a1651c059 : 165 + 0xe]
    eip = 0x019acf15   esp = 0xb7f0b290   ebp = 0xb7f0b398
    Found by: previous frame's frame pointer
22  libxul.so!_ZL10ThreadFuncPv [platform_thread_posix.cc:540a1651c059 : 26 + 0x5]
    eip = 0x019bfaf7   esp = 0xb7f0b3a0   ebp = 0xb7f0b3b8
    Found by: previous frame's frame pointer
23  libpthread-2.5.so + 0x52da
    eip = 0x00c042db   esp = 0xb7f0b3c0   ebp = 0xb7f0b4a8
    Found by: previous frame's frame pointer
24  libc-2.5.so + 0xcd12d
    eip = 0x001e112e   esp = 0xb7f0b4b0   ebp = 0x00000000
    Found by: previous frame's frame pointer
(Reporter)

Comment 1

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268682010.1268683836.16754.gz&fulltext=1#err6

Crash reason:  SIGSEGV
Crash address: 0x0

Thread 1 (crashed)
 0  libnptest.so!NPP_New [nptest.cpp:540a1651c059 : 96 + 0x0]
    eip = 0x00c46f89   esp = 0xb7f5bed0   ebp = 0xb7f5bf48   ebx = 0x00c4a5a8
    esi = 0x00000000   edi = 0x082070e0   eax = 0x00000012   ecx = 0x00a21ac8
    edx = 0x00a23bbc   efl = 0x00210282
    Found by: given as instruction pointer in context
 1  libxul.so!mozilla::plugins::PluginModuleChild::AnswerPPluginInstanceConstructor(mozilla::plugins::PPluginInstanceChild*, nsCString const&, unsigned short const&, nsTArray<nsCString> const&, nsTArray<nsCString> const&, short*) [PluginModuleChild.cpp:540a1651c059 : 1582 + 0x1a]
    eip = 0x01a64155   esp = 0xb7f5bf50   ebp = 0xb7f5bf88
    Found by: previous frame's frame pointer
 2  libxul.so!mozilla::plugins::PPluginModuleChild::OnCallReceived(IPC::Message const&, IPC::Message*&) [PPluginModuleChild.cpp : 519 + 0x1f]
    eip = 0x01a91768   esp = 0xb7f5bf90   ebp = 0xb7f5c018
    Found by: previous frame's frame pointer
 3  libxul.so!mozilla::ipc::RPCChannel::DispatchIncall(IPC::Message const&) [RPCChannel.cpp:540a1651c059 : 461 + 0xd]
    eip = 0x01a6f0bb   esp = 0xb7f5c020   ebp = 0xb7f5c058
    Found by: previous frame's frame pointer
 4  libxul.so!mozilla::ipc::RPCChannel::OnMaybeDequeueOne() [RPCChannel.cpp:540a1651c059 : 389 + 0x9]
    eip = 0x01a6f7de   esp = 0xb7f5c060   ebp = 0xb7f5c0a8
    Found by: previous frame's frame pointer
 5  libxul.so!RunnableMethod<mozilla::ipc::RPCChannel, void (mozilla::ipc::RPCChannel::*)(), Tuple0>::Run() [tuple.h:540a1651c059 : 383 + 0xd]
    eip = 0x01a7055d   esp = 0xb7f5c0b0   ebp = 0xb7f5c0c8
    Found by: previous frame's frame pointer
 6  libxul.so!mozilla::ipc::RPCChannel::DequeueTask::Run() [RPCChannel.h : 376 + 0xd]
    eip = 0x01a704b2   esp = 0xb7f5c0d0   ebp = 0xb7f5c0e8
    Found by: previous frame's frame pointer
 7  libxul.so!MessageLoop::RunTask(Task*) [message_loop.cc:540a1651c059 : 336 + 0x7]
    eip = 0x01b1cf51   esp = 0xb7f5c0f0   ebp = 0xb7f5c118
    Found by: previous frame's frame pointer
 8  libxul.so!MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) [message_loop.cc:540a1651c059 : 344 + 0x9]
    eip = 0x01b1d3e5   esp = 0xb7f5c120   ebp = 0xb7f5c138
    Found by: previous frame's frame pointer
 9  libxul.so!MessageLoop::DoWork() [message_loop.cc:540a1651c059 : 444 + 0xc]
    eip = 0x01b1d6e4   esp = 0xb7f5c140   ebp = 0xb7f5c188
    Found by: previous frame's frame pointer
10  libxul.so!base::MessagePumpForUI::RunWithDispatcher(base::MessagePump::Delegate*, base::MessagePumpForUI::Dispatcher*) [message_pump_glib.cc:540a1651c059 : 199 + 0xa]
    eip = 0x01b48216   esp = 0xb7f5c190   ebp = 0xb7f5c1e8
    Found by: previous frame's frame pointer
11  libxul.so!base::MessagePumpForUI::Run(base::MessagePump::Delegate*) [message_pump_glib.h:540a1651c059 : 59 + 0xd]
    eip = 0x01b486d4   esp = 0xb7f5c1f0   ebp = 0xb7f5c208
    Found by: previous frame's frame pointer
12  libxul.so!MessageLoop::RunInternal() [message_loop.cc:540a1651c059 : 216 + 0x8]
    eip = 0x01b1d146   esp = 0xb7f5c210   ebp = 0xb7f5c228
    Found by: previous frame's frame pointer
13  libxul.so!MessageLoop::RunHandler() [message_loop.cc:540a1651c059 : 199 + 0x7]
    eip = 0x01b1d16a   esp = 0xb7f5c230   ebp = 0xb7f5c248
    Found by: previous frame's frame pointer
14  libxul.so!MessageLoop::Run() [message_loop.cc:540a1651c059 : 173 + 0x7]
    eip = 0x01b1d1e1   esp = 0xb7f5c250   ebp = 0xb7f5c288
    Found by: previous frame's frame pointer
15  libxul.so!base::Thread::ThreadMain() [thread.cc:540a1651c059 : 165 + 0xe]
    eip = 0x01b29f15   esp = 0xb7f5c290   ebp = 0xb7f5c398
    Found by: previous frame's frame pointer
16  libxul.so!_ZL10ThreadFuncPv [platform_thread_posix.cc:540a1651c059 : 26 + 0x5]
    eip = 0x01b3caf7   esp = 0xb7f5c3a0   ebp = 0xb7f5c3b8
    Found by: previous frame's frame pointer
17  libpthread-2.5.so + 0x52da
    eip = 0x00c042db   esp = 0xb7f5c3c0   ebp = 0xb7f5c4a8
    Found by: previous frame's frame pointer
18  libc-2.5.so + 0xcd12d
    eip = 0x00b5e12e   esp = 0xb7f5c4b0   ebp = 0x00000000
    Found by: previous frame's frame pointer

Comment 2

9 years ago
These are intentional crashes, and are not the cause of the orange.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

9 years ago
Sorry, I thought all intentional crashes died in IntentionalCrash().
(maybe it is, but gcc inlined it?)
If not, how do we tell a real crash from an intentional?

Comment 4

9 years ago
Yeah, it appears that it was either inlined or the stack skipped the top frame. You can't really tell a real crash from an intentional one without looking at the stack, but normally a real crash will also have a test failure to go with it, e.g. "exited with code N" or "missing leak output".

Updated

8 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 539823
(Assignee)

Updated

7 years ago
Crash Signature: [@ libnptest.so!NPP_Destroy] [@ libnptest.so!NPP_New]
You need to log in before you can comment on or make changes to this bug.