Closed Bug 552575 Opened 15 years ago Closed 15 years ago

Feature request: Add a way to express dependencies between tasks

Categories

(Calendar :: Tasks, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 194863

People

(Reporter: carleeto, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

Frequently, a large task is due a few months down the line. As time progresses, it is broken up into smaller tasks, each of which may or may not have a sequence. Currently, there is no way to express sequences between tasks and/or their inter-dependencies.

Example: 
Task Q cannot start until tasks A and G are complete. 
Tasks A and G can be executed in parallel, but may have dependencies of their own.

This would really go a long way towards using tasks in a production environment. It would also enable really useful things like calculation of the quickest path to a goal. 

For example, I'm a developer and use tasks at work. It would absolutely rule if I could provide my managers with a feature map (which would be nothing but interdependent tasks) that they could use for reference to plan future versions of the software product. From a productivity point of view, this would save heaps of time - less meetings. 

We all want less meetings, don't we? :)

Reproducible: Couldn't Reproduce
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.