Closed Bug 552629 Opened 10 years ago Closed 10 years ago

nsIMsgCustomColumnHandler needs new iid because parent interface nsITreeView was changed

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set

Tracking

(blocking-thunderbird3.1 rc1+, thunderbird3.1 beta2-fixed)

RESOLVED FIXED
Thunderbird 3.1b2
Tracking Status
blocking-thunderbird3.1 --- rc1+
thunderbird3.1 --- beta2-fixed

People

(Reporter: pjemen, Assigned: pjemen)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: 

nsIMsgCustomColumnHandler was changed indirectly by inheritance from nsITreeView.

There were changed following methods in nsITreeView(they got new arguments).

Tb30/Gecko 1.9.0
boolean canDrop(in long index, in long orientation);
void drop(in long row, in long orientation); 

Tb31/Gecko 1.9.2
boolean canDrop(in long index, in long orientation, in nsIDOMDataTransfer dataTransfer);
void drop(in long row, in long orientation, in nsIDOMDataTransfer dataTransfer);


Reproducible: Always
blocking-thunderbird3.1: --- → ?
Version: unspecified → Trunk
Summary: nsIMsgCustomColumnHandler needs new iid because it parent interface nsITreeView was changed → nsIMsgCustomColumnHandler needs new iid because parent interface nsITreeView was changed
Attachment #432762 - Flags: review?(bugzilla)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Assignee: nobody → pjemen
blocking-thunderbird3.1: ? → rc1+
Attachment #432762 - Flags: superreview+
Attachment #432762 - Flags: review?(bugzilla)
Attachment #432762 - Flags: review+
Keywords: checkin-needed
Comment on attachment 432762 [details] [diff] [review]
proposed patch for nsIMsgCustomColumnHeader
[Checkin: Comment 2]


http://hg.mozilla.org/comm-central/rev/ed3132664862
Attachment #432762 - Attachment description: proposed patch for nsIMsgCustomColumnHeader → proposed patch for nsIMsgCustomColumnHeader [Checkin: Comment 2]
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1b2
You need to log in before you can comment on or make changes to this bug.