Status

Tamarin
Baseline JIT (CodegenLIR)
VERIFIED DUPLICATE of bug 551173
8 years ago
8 years ago

People

(Reporter: Brent Baker, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Not sure exactly what has started to cause this issue but it started around the time that the verifier change came into tamarin-redux-argo (which I think also contained a merge from nanojit-central).

This failure is happening in both tr and tr-argo (NOTE: in tr you still need to apply patch http://hg.mozilla.org/projects/nanojit-central/rev/3b1d24a51ce4 to compile on sparc, as of tr rev4030)

Running most acceptance testcases results in the following error:
test/acceptance/ecma3/Date/e15_9_5_4.abc

15.9.5.4 Date.prototype.toTimeString()
t@1 (l@1) signal SEGV (no mapping at the fault address) in nanojit::LIns::opcode at line 400 in file "LIR.h"
  400           LOpcode opcode() const { return lastWord.opcode; }
Flags: flashplayer-qrb?
(Reporter)

Comment 1

8 years ago
There is another SPARC tracking bug #551173 for acceptance failures, it does not appear to be the same issue to me but cross commenting anyways.
(Reporter)

Comment 2

8 years ago
Same error happens in TR and TR-Argo, just code location is slightly different, but same code:

TR-Argo:
t@1 (l@1) signal SEGV (no mapping at the fault address) in nanojit::LIns::opcode at line 400 in file "LIR.h"
  400           LOpcode opcode() const { return lastWord.opcode; }

TR:
t@1 (l@1) signal SEGV (no mapping at the fault address) in nanojit::LIns::opcode at line 493 in file "LIR.h"
  493           LOpcode opcode() const { return lastWord.opcode; }

Comment 3

8 years ago
I just confirmed, it is the same bug as bug 551173. In mozilla tree we use -xO2 to compile Assembler.cpp instead of -xO5 as a workaround.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551173
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
Flags: flashplayer-qrb?
You need to log in before you can comment on or make changes to this bug.