Customised keyboard shortcuts don't work on OS X

RESOLVED DUPLICATE of bug 429824

Status

()

defect
RESOLVED DUPLICATE of bug 429824
9 years ago
9 years ago

People

(Reporter: nathanielvirgo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

At least for some menu items, defining keyboard shortcuts via OS X's keyboard.prefpane doesn't seem to work.  The menu flashes blue, as expected, but the action doesn't get performed.

Reproducible: Always

Steps to Reproduce:
1. Open OS X system preferences and select the "keyboard" pane, then "keyboard shortcuts".
2. Define a new keyboard shortcut for a Firefox menu item -- I used "No Style" (under View->Page Style), and assigned the shortcut command-] (I also tried several others)
3. Restart Firefox
4. Try to use the new shortcut.
Actual Results:  
The menu (in this case the View menu) flashes blue, but other than that nothing happens.

Expected Results:  
The appropriate action should have been performed - in this case switching to the default style sheet.

This might be related to bug 535978 (but it is a different issue)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.