Changed login on AMO does not propagate to Collector

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Collections
P3
normal
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: kinger, Unassigned)

Tracking

unspecified
4.x (triaged)
x86
All

Details

Attachments

(2 attachments)

Created attachment 434577 [details]
Simulated API dialog before changing my AMO email (working).
Created attachment 434578 [details]
Simulated API dialog after changing my AMO email (not working)
I can reproduce this, however it looks to be a server issue. See attached API dialog comparison for details.
(Reporter)

Comment 4

8 years ago
Dave,

Can you hone in for us on the particular data that points to it being a server issue.
(Reporter)

Updated

8 years ago
Target Milestone: BW-1.1.1 → BW-1.1.2
The first authentication call (before changing my email) works as expected - a valid authentication token is returned and I can download my list of collections.

The second authentication call (after changing my email) does not work - a authentication token is returned, but further API calls with that token are rejected with an "unauthorized" error.

Since nothing has changed on the client side (we only store tokens locally, not usernames or email) then the assumption is that the server API does not handle email changes correctly - perhaps some table is incorrectly indexed on email not id.
(Reporter)

Comment 6

7 years ago
Les,

Are you still working on Collections these days. Is this something you can look into?
Assignee: dave → nobody
Component: Collector Extension → Collections
QA Contact: collector-extension → collections
(Reporter)

Updated

7 years ago
Assignee: nobody → lorchard
Target Milestone: BW-1.1.2 → ---
Version: BW-1.1.x → unspecified
No, I haven't worked on AMO in a year or so
Assignee: lorchard → nobody
Dave is working on the API these days.
Assignee: nobody → dd
Priority: P1 → P3
Target Milestone: --- → 4.x (triaged)
Assignee: dd → nobody
(Reporter)

Comment 9

6 years ago
Collector 2.1 is shipping in a matter of days and it will be the last version in its current form. The API will not longer be maintained --> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.