Thunderbird tries to open .docx as .docx.txt but saves correctly ((Tb can't detect mime-type of Content-type:[CRLF]application/vnd.openxmlformats-officedocument.wordprocessingml.document;)

RESOLVED DUPLICATE of bug 538641

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 538641
8 years ago
8 years ago

People

(Reporter: M Koch, Unassigned)

Tracking

Other
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [penelope_wants], URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTB6
Build Identifier: Thunderbird 3.0.3

I have office 2003 with the patch to read 2007 documents.
When I receive a *.docx it saves correctly and can be opened in word but if I try to open by double clicking the attachment it becomes *.docx.txt and neither Word nor Notepad can open it.  The icon in front of *.docx is a notepad.  I tried adding OpenAttachmentByExtension 0.3.1 but it made no difference.  This happens to me every time but I have not been able to try it on other computers.  As far as I can tell other attachments, such as .doc .xls .wvm .gif , open normally.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
My Computer is a Dell Optiplex GX520
Version: unspecified → 3.0

Comment 2

8 years ago
Maybe related to Firefox bug 462915? See also Penelope bug 524991.
I haven't been able to reproduce this!
From http://gsfn.us/t/tu1y here's what I tried
1. created testfile.docx
2. sent it from gmail.com's web interface as an attachment to my hotmail account
3. on Windows 7, used Thunderbird 3.0.3 to read the email with the attached testfile.docx from my hotmail account
4. Selected the attachment, right clicked and selected open
5. Document opened as testfile.docx in WordPad (I don't have Word but as far as I know if it opens in WordPad it should open in Microsoft Word). I also verified the filename was correct i.e. testfile.docx

Comment 4

8 years ago
I have the same problem reported here but on Mac OS X (Snow Leopard 10.6.2) and Thunderbird 3.0.3. Doc and Excel files from older format work fine but the .docx and .xlsx files launch in TextEdit, even when I set the attachment settings in Thunderbird for those file types. Reproducible every time, and I don't even get a right-clickable "open with" option for those files - I have to save and open each time.

I have Thunderbrowse 3.2.8.1 installed, not sure if that would have an impact.
(In reply to comment #4)
> I have the same problem reported here but on Mac OS X (Snow Leopard 10.6.2) and
> Thunderbird 3.0.3. Doc and Excel files from older format work fine but the
> .docx and .xlsx files launch in TextEdit, even when I set the attachment
> settings in Thunderbird for those file types. Reproducible every time, and I
> don't even get a right-clickable "open with" option for those files - I have to
> save and open each time.
> 
> I have Thunderbrowse 3.2.8.1 installed, not sure if that would have an impact.

Hi abarclay:

This works fine in Mac Lanikai beta 2 pre 20100326 i.e.
.docx opens in TextEdit correctly

Could you try: 3.0.3 without Thunderbrowse 
as well as if you have time and energy and know how to use Beta software, try with 3.1 beta 2 pre ?
Created attachment 435770 [details]
Word 2007 (or Word 2003 with 2007 patch) file that Thunderbird 3.0.3 incorrectly opens as .txt

reproduced the problem with ".docx from word 2007 being opened as .txt files" in 
http://getsatisfaction.com/mozilla_messaging/topics/docx_and_thunderbird_dont_mix#reply_2137161

workaround:
Note that we don't support this add-on. It appears to work (i.e. it works for me with WordPad and Windows 7) so I recommend trying it and if it works for you to use it.

A. In Firefox https://nic-nac-project.org/~kaosmos/...
B. In Firefox: Right click on Download and save OpenAttachmentsByExtension-0.31 to your desktop
C. In Thunderbird: Tools->Add-ons->Get Add-ons tab->Click "Install..."->navigate to your desk top and select OpenAttachmentByExtension-0.31 that you downloaded in Step B. and click "Open" and then "Install Now"
D. Click "Restart Thunderbirddoc
E. In Thunderbird Tools->Add-ons->Extensions tab->Options->Add
type ".docx" for Extension and then click Browse
Navigate to WordPad (Computer->Program Files->Windows NT->Accessories-> select WordPad and then Open) or your version of Word 2003 or 2007

F. Now when you open .docx WordPad or Word (as configured in step E) should open the .docx file correctly instead of incorrectly appending a .txt suffix

Comment 7

8 years ago
Tried disabling and then uninstalling Thunderbrowse - no impact, both docx and xslx open in TextEdit and the attachment icons show as text, not Word or Excel.

Poked around on the Thunderbird site and can't seem to find a download of 3.1 beta 2 prerelease (seems to end at alpha or beta 1, I forget which). Can someone provide a link to the download? I'd be happy to test it after backing up my mail tonight...
(Reporter)

Comment 8

8 years ago
I just upgraded to Thunderbird 3.0.4, with the extension OpenAttachmentByExtension-0.3.1, I still have office 2003 with the 2007 patch.
I sent myself a new test document, a .docx that opens from the drive, and tried to open it in Thunderbird. It had the notepad icon but it tried to open in Word.
Same error as before.<sigh>

Updated

8 years ago
Whiteboard: [penelope_wants]

Updated

8 years ago
Duplicate of this bug: 524991

Comment 10

8 years ago
Same problem in Win XP SP3 TB3.0.4, sending an email from my gmail account I received it in Thunderbird with a MimeType (view message source):

Content-Type: 
 application/vnd.openxmlformats-officedocument.wordprocessingml.document; 


I use OpenOffice 3.2 to open OOXML files, but TB recognize the file like a 'text/plain' and try to open it with wordpad or notepad, but when I select OpenOffice this give me an error about encoding because 'thinks' that the file is a text plain file.

Comment 11

8 years ago
I believe I have a related problem but it only happens in specific cases. In lieu of opening a new ticket, I figure I'll add my steps to reproduce my version of this problem.

This is always reproducible on at least two machines in my control.
1. Compose messages to self
2. In body select Insert->Characters and symbols->Accent Lowercase ->Letter:e character: é
3. Attach an Office 2007 .docx file (or .xlsx)

Actual Results:
Attachment pane displays text document icon next to .docx file.
Double clicking on .docx attachment tries to open "Text document" in notepad.
Right clicking and using Save As correctly saves file as .docx.
If Display attachments inline is selected thunderbird will incorrectly render .docx file as garbled characters beneath the body of the email. I will add an attachment of the display and original message.

Expected Results:
Attachment should display office document icon. (It does if the message doesn't include the accent character)
Double clicking attachment should open Office not Notepad (It does if the message doesn't include the accent character)
Attachment should display attachment inline (or not at all if it can't be rendered properly) if "Display Attachments Inline" is selected (It doesn't attempt to display inline if the message doesn't include the accent character)

Comment 12

8 years ago
Created attachment 444886 [details]
Image of incorrect rendering of .docx file and incorrect icon in attachments pane

If email body contains accent character .docx and .xlsx files are incorrectly rendered inline and attachment icon is incorrect.

Comment 13

8 years ago
Created attachment 444887 [details]
Source of email that renders .docx inline incorrectly and with wrong attachment icon

This email containing an accent character will incorrectly try to display a .docx file inline and displays a text icon instead of an office icon.
(Reporter)

Comment 14

8 years ago
I have discovered that if I send a .docx to an email list I am on I can open the docx in the sent folder by clicking on it, but I can not open the one that arrives from the email list.  It does not matter if I move them to different folders.  the docx that never leaves my email works, the one that goes out on the web and back again does not!

Comment 15

8 years ago
Mine exhibits the same behavior. Below is a partial output of Thunderbird run with debug enabled.  It seem that between SetCurrentURI and "Getting mimeinfo from type..." they are behave differently.

Reading email from Sent folder
0[182e140]: DOCSHELL 2df8e00 SetCurrentURI imap://Brian%2EKeffer@mail.nems.noaa.gov:993/fetch%3EUID%3E/Sent%3E7743
0[182e140]: Getting mimeinfo from type 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet' ext '.xlsx'
0[182e140]: Windows mime database: extension '.'
0[182e140]: Extension lookup on '.' found: 0x1c0bb20
0[182e140]: Appending extension '.xlsx' to mimeinfo, because its mimetype is 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet'
0[182e140]: OS gave back 0x1c0bb20 - found: 1
0[182e140]: Extension '.xlsx' matches mime info: 1
0[182e140]: MIME Info Summary: Type 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet', Primary Ext '.xlsx'
0[182e140]: Getting mimeinfo from type 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet' ext '.xlsx'
0[182e140]: Windows mime database: extension '.'
0[182e140]: Extension lookup on '.' found: 0x1c0bca0
0[182e140]: Appending extension '.xlsx' to mimeinfo, because its mimetype is 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet'
0[182e140]: OS gave back 0x1c0bca0 - found: 1
0[182e140]: Extension '.xlsx' matches mime info: 1
0[182e140]: MIME Info Summary: Type 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet', Primary Ext '.xlsx'
0[182e140]: Getting mimeinfo from type 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet' ext '.xlsx'
0[182e140]: Windows mime database: extension '.'
0[182e140]: Extension lookup on '.' found: 0x1c88160
0[182e140]: Appending extension '.xlsx' to mimeinfo, because its mimetype is 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet'
0[182e140]: OS gave back 0x1c88160 - found: 1
0[182e140]: Extension '.xlsx' matches mime info: 1
0[182e140]: MIME Info Summary: Type 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet', Primary Ext '.xlsx'

Reading email from Inbox
0[182e140]: DOCSHELL 2df8e00 SetCurrentURI imap://Brian%2EKeffer@mail.nems.noaa.gov:993/fetch%3EUID%3E/INBOX%3E19234
0[182e140]: Getting mimeinfo from type 'text/plain' ext '.xlsx'
0[182e140]: Windows mime database: extension '.'
0[182e140]: Extension lookup on '.' found: 0x4c38040
0[182e140]: OS gave back 0x4c38040 - found: 1
0[182e140]: Extension '.xlsx' matches mime info: 0
0[182e140]: MIME Info Summary: Type 'text/plain', Primary Ext 'txt'
0[182e140]: Getting mimeinfo from type 'text/plain' ext '.xlsx'
0[182e140]: Windows mime database: extension '.'
0[182e140]: Extension lookup on '.' found: 0x4c384c0
0[182e140]: OS gave back 0x4c384c0 - found: 1
0[182e140]: Extension '.xlsx' matches mime info: 0
0[182e140]: MIME Info Summary: Type 'text/plain', Primary Ext 'txt'

Comment 16

8 years ago
Nearly the same issue on Mac OS 10.6.3 and Thunderbird 3.0.6.pre with Lightning and Personas installed.

Thunderbird tries to render the docx in the message windows but displays bogus characters. It does, however, open correctly with OpenOffice (not a plain-text editor or the like).
Summary: Thunderbird tries to open .docx as .docx.txt but saves correctly → Thunderbird tries to open .docx as .docx.txt but saves correctly ((Tb can't detect mime-type of Content-type:[CRLF]application/vnd.openxmlformats-officedocument.wordprocessingml.document;)
dup of bug 538641?
(Reporter)

Comment 18

8 years ago
Yes, it certainly seems to be a dupe of bug 537641!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537641
(Reporter)

Comment 20

8 years ago
Sorry I meant bug 538641
(Reporter)

Updated

8 years ago
Duplicate of bug: 538641
(Reporter)

Comment 22

8 years ago
(In reply to comment #18)
> Yes, it certainly seems to be a dupe of bug 537641!

(In reply to comment #19)
> 
> *** This bug has been marked as a duplicate of bug 537641 ***

No, no that was a typo, it is a duplicate of 538641
Depends on: 538641
(Reporter)

Comment 23

8 years ago
Thunderbird 3.1 appears to not have this problem, yea!
You need to log in before you can comment on or make changes to this bug.