Crash when trying to access www.clarkson.edu with java plugin installed.

VERIFIED WORKSFORME

Status

Core Graveyard
Java: OJI
P3
critical
VERIFIED WORKSFORME
17 years ago
7 years ago

People

(Reporter: Mike Akers, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test6 i686; en-US; m18) Gecko/20001004
BuildID:    2000100409

Mozilla crashes on this page due to the java applet. The applet seems to load
and start running, but moz crashes. If I dont have the oji plugin installed,
mozilla has no problem with this page (other than complaining about the lack of
oji :).

Reproducible: Always
Steps to Reproduce:
1.start mozilla with oji plugin installed
2.goto www.clarkson.edu
3.

Actual Results:  Mozilla crashes shortly after the applet on the page loads.					

Expected Results:  Mozilla shouldnt crash and the applet should happily run :)					

The oji plugin I'm using is the one from netscape 6 pr3. I just copied the
contents of plugins/ from my pr3 install to plugins/ in my mozilla directory, If
this is not the proper way to get java working in mozilla, let me know.

The applet runs properly in appletviewer from suns jdk 1.3


here's what gets printed to the console:

Create instance called in JavaPluginFactory5!!!!!!!!
 Succeeding in creating proxy
Register Env [0] proxyenv=140938512 tid=134579128
initilizing the java plugin instantance
Plugin worker error: Operation not supported
Plugin: trouble with work request from child (3)
Plugin: Java VM process has died.
Spontaneous thread waiting for next request...
INTERNAL ERROR on Browser End: Pipe closed during read? State may be corrupt
System error?:: Success

Comment 1

17 years ago
cc self

Comment 2

17 years ago
Finally got the java plugin working so I could test this (you can install it at 
http://home.netscape.com/plugins/jvm.html).
I didn't get a crash but performance on clarkson's page is pretty terrible but 
that might be due to the jre rather than mozilla and it's probably a separate 
issue either way.

Comment 3

17 years ago
I downloaded the plugin (does exist some mirror? the server is the slowest
I had ever seen :-(). It does function well with Navigator 4.73, but Mozilla
(linux build 102021 and previous) crash with every page (e.g.
www.mozillazine.org) with java applets.

The console output of the whole session (from startup to crash... sorry, but
talkback does not catch the crash) follows:

-----------------------------------------------------------------------------
/opt/mozilla/run-mozilla.sh /opt/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/opt/mozilla

LD_LIBRARY_PATH=/opt/mozilla:/opt/mozilla/plugins/java2/lib/i386:/opt/mozilla/plugins/java2/lib/i386/client:/opt/mozilla/plugins/java2/lib:/home/marcenuc/opt/lib
     LIBRARY_PATH=/opt/mozilla:/opt/mozilla/components
       SHLIB_PATH=/opt/mozilla
          LIBPATH=/opt/mozilla
       ADDON_PATH=/opt/mozilla
      MOZ_PROGRAM=/opt/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
before calling the services
Failed to create Java VM
Move window by 639.5,511.5
New location for profile registry and user profile directories is ->
/home/marcenuc/.mozilla
start with profile: marcenuc
ProfileManager : StartApprunner
profileName passed in: marcenucSetting content window
*** Pulling out the charset
Loading page specified via openDialog
in SetSecurityButton
Document about:blank loaded successfully
Create instance called in JavaPluginFactory5!!!!!!!!
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: File o directory inesistente
Gdk-ERROR **: Fatal IO error 9 (Descrittore di file non valido) on X server :0.0.
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Risorsa temporaneamente non disponibile

-----------------------------------------------------------------------------

NOTE: here's the translation of italian messages:

"File o directory inesistente" = "File or directory not found"
"Descrittore di file non valido" = "Invalid file descriptor"
"Risorsa temporaneamente non disponibile" = Resource temporarily not available"

Comment 4

17 years ago
just a data point:  seems to be linux specific.  wfm on WinNT 2000101608

Comment 5

17 years ago
looks good with new jre for linux on branch 10/27 build.WFM. Mike, pls verify.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
I just crashed with a clean install of 2000102708/trunk and jvm from
http://home.netscape.com/plugins/jvm.html
Is the xpi package at the above address updated?

Comment 7

17 years ago
ah...I doubt the bits on netcenter are the latest one. We just have them updated 
internally here. I am not sure when they are going to do this. Will comment once 
the bits get updated.Thanks !
(Reporter)

Comment 8

17 years ago
ok, the applet works now with the jre from ns6. Thanks guys.

Comment 9

17 years ago
great, marking VERIFIED !
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.