numerous msgs fprintf()ed to the console, e.g. "(child won, so we're deferring)"

RESOLVED FIXED in mozilla1.9.3a5

Status

()

Core
IPC
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: George R. Goffe, Assigned: Gavin)

Tracking

1.9.2 Branch
mozilla1.9.3a5
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking1.9.2 -, status1.9.2 .5-fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4pre) Gecko/20100316 Minefield/3.7a4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4pre) Gecko/20100316 Minefield/3.7a4pre

After starting firefox the following messages appear:

(<unknown>:5086): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

(<unknown>:5086): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

(<unknown>:5086): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
  (child won, so we're not deferring)
  (child won, so we're deferring)
  (processing deferred in-call)
  (child won, so we're not deferring)
  (child won, so we're deferring)
  (processing deferred in-call)
  (child won, so we're not deferring)
  (child won, so we're deferring)
  (processing deferred in-call)
  (child won, so we're not deferring)
  (child won, so we're deferring)
  (processing deferred in-call)
  (child won, so we're deferring)
  (child won, so we're not deferring)
  (processing deferred in-call)
  (child won, so we're deferring)
  (child won, so we're not deferring)
  (processing deferred in-call)


Reproducible: Always

Actual Results:  
error msgs(?) appear.

Expected Results:  
no error msgs appear.

This system is up to date according to yum repos available.

shooter bash-4.0 ~# uname -a
Linux shooter.sleazegate.com 2.6.32.9-70.fc12.i686 #1 SMP Wed Mar 3 05:14:32 UTC 2010 i686 i686 i386 GNU/Linux
shooter bash-4.0 ~# cat /etc/redhat-release 
Fedora release 12 (Constantine)

Comment 1

8 years ago
The same problem exists with Fx 3.6.4 build1. Per gavin on IRC, this is not desired.
Status: UNCONFIRMED → NEW
blocking1.9.2: --- → ?
Ever confirmed: true
Version: unspecified → 3.6 Branch
Component: General → IPC
Product: Firefox → Core
QA Contact: general → ipc
Version: 3.6 Branch → 1.9.2 Branch
An annoyance; wanted, not blocking.
blocking1.9.2: ? → -
status1.9.2: --- → wanted
Created attachment 443754 [details] [diff] [review]
remove fprintfs

Is there any reason not to just remove these?

I left the ones in DumpRPCStack() and DebugAbort(), since I'm assuming they're only hit in exceptional circumstances.
Attachment #443754 - Flags: review?(jones.chris.g)
Comment on attachment 443754 [details] [diff] [review]
remove fprintfs

Yes, these are very useful when debugging.

Make these |if (LoggingEnabled())| please (see ipc/glue/ProtocolUtils.h).
Attachment #443754 - Flags: review?(jones.chris.g) → review-
Created attachment 444207 [details] [diff] [review]
patch
Assignee: nobody → gavin.sharp
Attachment #443754 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #444207 - Flags: review?(jones.chris.g)
Comment on attachment 444207 [details] [diff] [review]
patch

Thanks.
Attachment #444207 - Flags: review?(jones.chris.g) → review+
Keywords: checkin-needed

Comment 7

8 years ago
Comment on attachment 444207 [details] [diff] [review]
patch

This should land for Fx 3.6.4/5 too.
Attachment #444207 - Flags: approval1.9.2.5?
Attachment #444207 - Flags: approval1.9.2.4?
Summary: numerous msgs "(child won, so we're deferring)" → numerous msgs fprintf()ed to the console, e.g. "(child won, so we're deferring)"
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/0de1a3677f6a
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
OS: Linux → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Attachment #444207 - Flags: approval1.9.2.4?
Attachment #444207 - Flags: approval1.9.2.5? → approval1.9.2.5+
Comment on attachment 444207 [details] [diff] [review]
patch

a=beltzner for 1.9.2 default
Keywords: checkin-needed
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/638bed07f086
status1.9.2: wanted → .5-fixed
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.