Content of the document is large but scrollbars are not visible

RESOLVED DUPLICATE of bug 550882

Status

()

Core
Layout: Text
--
major
RESOLVED DUPLICATE of bug 550882
8 years ago
8 years ago

People

(Reporter: michal.sidlo, Unassigned)

Tracking

({regression, testcase})

1.9.2 Branch
All
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Firefox 3.6

Try the HTML document inserted into "Steps to reproduce"

Reproducible: Always

Steps to Reproduce:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<html>
<head>
<title>Missing scrollbars in Firefox 3.6</title>
<script type="text/javascript">

function el(id)
{
	return document.getElementById(id);
}

function attachEvent2(o, type, listener)
{
  if (o.addEventListener) { o.addEventListener(type, listener, false); return true; }
  if (o.attachEvent) return o.attachEvent('on' + type, listener);
}

</script>
</head>

<body bgColor="#ffffff" style="OVERFLOW: hidden">

<div id="div" style="Z-INDEX: 100000; POSITION: absolute; BACKGROUND-COLOR: white; WIDTH: 3000px; HEIGHT: 3000px; TOP: 0px; LEFT: 0px">
Please wait...
</div>

<div>
<font size="6">
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
Missing scrollbars in Firefox 3.6 Missing scrollbars in Firefox 3.6
</font>
</div>

<script type="text/javascript">
attachEvent2(window, 'load', function() { el('div').style.display = 'none'; document.body.style.overflow = 'auto'; });
</script>

</body>
</html>
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a4pre) Gecko/20100316 Minefield/3.7a4pre

This is a regression from Firefox 3.5.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted, testcase
Version: unspecified → 1.9.2 Branch
Component: General → Layout: Text
QA Contact: general → layout.fonts-and-text
(Reporter)

Comment 3

8 years ago
Yes, I tested it in Firefox 3.5 too and it was OK.
> <body bgColor="#ffffff" style="OVERFLOW: hidden">

That means "don't put scrollbars on the viewport".

So the bug is THAT dynamically switching from that to "auto" doesn't work.  That would be bug 550882
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550882
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.