If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FIX][MF]keypress events doesn't bubble on html select elements

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Martin Enlund, Assigned: rods (gone))

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
F-keys (F1-F12) doesn't bubble properly on html select elements, as compared to
normal html or xul elements.

Verified on 
"Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m18) Gecko/20001002"
And a nightly from 2000-09-15.
(Reporter)

Comment 1

17 years ago
Created attachment 16212 [details]
XUL test case with keyset. (For installation, read inside)

Comment 2

17 years ago
Is this broken only on Linux or is it broken across all Platform/OS?

Comment 3

17 years ago
Reporter is this still a problem in the latest nightlies?
maren@lysator.liu.se - could you please update the instructions for this test 
case (assuming the bug still exists) in light of the jar-ification of chrome?

Gerv

Comment 5

17 years ago
I tried the testcase and nothing was dumped. But, what is really supposed to
happen? Reporter could you tell us what exactly should happen? The visual
effects I mean.
Thank you,
Fabian.

Comment 6

17 years ago
Marking INVALID due to lack of response. Reopen if this is still a problem.

Comment 7

17 years ago
Whoops didnt change it..Marking invalid again..sorry for the spam
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

17 years ago
Created attachment 20742 [details]
Updated test-case
(Reporter)

Comment 9

17 years ago
Verified on linux with latest nightly (2000-12-15). 
(See the xul file for installation details.)
 
Fabian: When pressing the two different elements one xul:button and one
html:select and thus focusing them, and then pressing F-keys (F1-F12) Mozilla
should print out (in the console) what key was pressed. (As defined in the
keyset).

I'm downloading a Mozilla nightly for windows now and will post the results
later.

(Sorry for being such a lazy bum ;)

Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 10

17 years ago
Verified on Windows 2000 with latest nightly. 
Remember that only F3 and F12 is mapped in the keyset, so you only get output
for those in the console.

Comment 11

17 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 12

17 years ago
Now I've gone through nsListControlFrame.cpp and I've seen the problem.
Apparently we patch away *all* bubbling not caring whether we actually handle
the incoming key-event or not.
However, letting all events bubble produce seems bad as well, so my suggestion
is to let all key-events we don't handle bubble up.
If anyone wants, I could make a patch for this.
(Assignee)

Comment 13

17 years ago
Sure, make the patch. All help is welcome.
Status: NEW → ASSIGNED
(Reporter)

Comment 14

17 years ago
Created attachment 25456 [details] [diff] [review]
Patch to let all key events we didn't handle bubble up.
(Assignee)

Updated

17 years ago
Summary: F1-F12 events doesn't bubble on html select elements → [FIX][MF]F1-F12 events doesn't bubble on html select elements
(Assignee)

Comment 15

17 years ago
I have some other patches sitting in my tree and I am going to try to get this 
in soon.
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.1

Comment 16

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Updated

16 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 17

16 years ago
I tested this, and keypress events dont bubble through selects, not only the
function keys.
Summary: [FIX][MF]F1-F12 events doesn't bubble on html select elements → [FIX][MF]keypress events doesn't bubble on html select elements

Comment 18

16 years ago
oh, and this was happening on windows 98, marking OS all
OS: Linux → All
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Comment 19

16 years ago
moving to 0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 20

16 years ago
*** Bug 103852 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 21

16 years ago
Moving to Future
Target Milestone: mozilla0.9.6 → Future
(Assignee)

Updated

16 years ago
Priority: P3 → --
Attachment #20742 - Attachment mime type: text/xul → application/vnd.mozilla.xul+xml
Created attachment 135463 [details]
Testcase

This exercises the code this bug was patching (ListControlFrame).
And if that patch fixed this bug, it worksforme (note that code inspection shows
that the PreventBubble call in question has been long removed).
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.