CFBundleIdentifier in /browser/app/macbuild/Contents/Info.plist.in is hardcoded as "org.mozilla.firefox"

RESOLVED FIXED in Firefox 3.7a4

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: christian, Assigned: reed)

Tracking

unspecified
Firefox 3.7a4
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The CFBundleIdentifier in /browser/app/macbuild/Contents/Info.plist.in is hardcoded as "org.mozilla.firefox", which could potentially cause default browser issues when running minefield and firefox on the same machine.

Running:

$ /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -dump | grep -C 4 org.mozilla.firefox | grep -i path: | grep -v Volumes | uniq
	path:          /Applications/Minefield.app
	path:          /Users/legnitto/src/mozilla-central/obj-x86_64-apple-darwin10.2.0/dist/Minefield.app
	path:          /Applications/Firefox.app

shows me the paths launch services associates with org.mozilla.firefox (notice minefield in there).

There are other hardcoded references to firefox in Info.plist.in which may need to be changed as well.
(In reply to comment #0)
> The CFBundleIdentifier in /browser/app/macbuild/Contents/Info.plist.in is
> hardcoded as "org.mozilla.firefox", which could potentially cause default
> browser issues when running minefield and firefox on the same machine.

Definitely does cause issues (at least I'll believe this is the root cause). Links from external apps will open in whichever you've opened first. Open Minefield, open Firefox (different profile), restart Minefield - links from external apps will open in Firefox even though I want them to open in Minefield (and expect them too - Safari shows it as the default browser).
Created attachment 433185 [details] [diff] [review]
patch - v1

Something like this?
Assignee: nobody → reed
Status: NEW → ASSIGNED
Attachment #433185 - Flags: review?(ted.mielczarek)
Comment on attachment 433185 [details] [diff] [review]
patch - v1

I'd rather josh took a look at this. It sounds reasonable, but I'm not sure what effect it has on remoting etc.
Attachment #433185 - Flags: review?(ted.mielczarek) → review?(joshmoz)

Comment 4

9 years ago
Comment on attachment 433185 [details] [diff] [review]
patch - v1

I'm fine with what this appears to do, but I'm not a good reviewer for the mechanics of the patch. That looks alright to me, fwiw though.
Attachment #433185 - Flags: review?(joshmoz) → review+
http://hg.mozilla.org/mozilla-central/rev/6387e3a7dd75
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a4
Duplicate of this bug: 491362
Duplicate of this bug: 387834
My Minefield build (20100324) is now identified as "Unknown Application" in the Spaces prefs (and probably elsewhere that I haven't noticed) -- is this intended?
Minefield also asked me to set it as the default when I started it up, to which I responded 'yes' - but now all my links in external apps open in Safari :(
I'm nearly certain that Minefield isn't supposed to identify as "Unknown Application", and certain that setting it as my default browser should work. Re-opening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #10)
> I'm nearly certain that Minefield isn't supposed to identify as "Unknown
> Application", and certain that setting it as my default browser should work.

http://beardendesigns.com/blogs/permalink/38-Get_Spaces_and_Netbeans_working_together talks about a similar problem. Based on what the post mentions, maybe try moving the entire Minefield folder out of Applications and deleting its association in Spaces. Once that's done, then move it back and see if it works.

I don't even own a Mac or have OS X, so not much I can personally do to debug this myself.
(In reply to comment #11)
> (In reply to comment #10)
> > I'm nearly certain that Minefield isn't supposed to identify as "Unknown
> > Application", and certain that setting it as my default browser should work.
> 
> http://beardendesigns.com/blogs/permalink/38-Get_Spaces_and_Netbeans_working_together
> talks about a similar problem. Based on what the post mentions, maybe try
> moving the entire Minefield folder out of Applications and deleting its
> association in Spaces. Once that's done, then move it back and see if it works.

This fixed both Spaces, and the default browser problem. I think we need to stop from every happening though, if we ever want to ship it ;-).
I filed bug 554997 for those issues.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Would be good to get someone to test the patch before landing in the future...)

Comment 15

9 years ago
The initial report was about something that "could potentially cause default-browser issues".  We've landed an untested patch that definitely does cause default-browser issues.  Bug 554997 doesn't have a solution for this issue yet.  Shouldn't we just back this out?
(Reporter)

Comment 16

9 years ago
I don't believe this should be backed it. This fix is correct, there is a workaround to the "regression" and the fix to bug 554997 should be trivial.

I'm new though so I am not sure about the general way of Bugzilla (back this out and wait until bug 554997 lands or keep this in and use the workaround/wait for bug 554997).

I also posted to planet with the workaround in bug 554997.
Blocks: 555785

Comment 17

9 years ago
I don't think it's reasonable to expect that our users will research or use a workaround like this.  We should back out the regressing bug until the workaround isn't required.
(Reporter)

Comment 18

9 years ago
Again, bug 554997 will not impact any users of a branded build. Aren't nightly/trunk testers assumed to be reasonably tech-savvy?

I don't really care all that much, just playing devil's advocate.
Duplicate of this bug: 561418
(Reporter)

Updated

9 years ago
Duplicate of this bug: 554997
You need to log in before you can comment on or make changes to this bug.