If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sophiestication.com/articles/ web page displays only one large screenshot instead of many small screenshots

RESOLVED WORKSFORME

Status

Camino Graveyard
Page Layout
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.18) Gecko/2010021619 Camino/2.0.2 (like Firefox/3.0.18)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.18) Gecko/2010021619 Camino/2.0.2 (like Firefox/3.0.18)

Camino displays only one iPhone screenshot and the image is in its large zoomed state. The Mac Firefox and Safari browsers display this web page's iPhone screenshots are all visible.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://www.sophiestication.com/articles/
2. There is no step 2
Actual Results:  
Camino displays only one iPhone screenshot and the image is in its large zoomed state.

Expected Results:  
The Mac Firefox and Safari browsers display this web page's iPhone screenshots are all visible.

This website uses the MooTools JavaScript library.
(Reporter)

Comment 1

8 years ago
Created attachment 433255 [details]
Camino screenshot
(Reporter)

Comment 2

8 years ago
Created attachment 433256 [details]
Firefox screenshot

Comment 3

8 years ago
The stylesheet uses a number of selectors and properties that are not supported by Gecko 1.9.0 (version used by Camino).

sample:
.preview:nth-child(1n) {
    -webkit-transform: scale(0.30) rotate(-8deg) translate(-275%, -20%);
    -moz-transform: scale(0.30) rotate(-8deg) translate(-275%, -20%);
    -o-transform: scale(0.30) rotate(-8deg) translate(-275%, -20%);
    -ms-transform: scale(0.30) rotate(-8deg) translate(-275%, -20%);
    transform: scale(0.30) rotate(-8deg) translate(-275%, -20%);
}

(the page works correctly with the experimental gecko-1.9.2 based camino builds).
Unless philippe wants to track down the relevant bug to dupe this to, I'm going to just close it WFM in Gecko 1.9.2.

Chris, we've got experimental builds with Gecko 1.9.2 at http://ftp.mozilla.org/pub/mozilla.org/camino/nightly/experimental/ (hopefully going to generate a new one this weekend).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.