search fails with non-ascii characters in API 1.2 and 1.3 URLs

RESOLVED DUPLICATE of bug 551991

Status

addons.mozilla.org Graveyard
API
RESOLVED DUPLICATE of bug 551991
8 years ago
2 years ago

People

(Reporter: Pratibha, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Mozilla Identifier:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.18) Gecko/2010020220 Firefox/3.0.18 (.NET CLR 3.5.30729) FBSMTWB

API 1.2 URL Search: FAIL
https://preview.addons.mozilla.org/en-US/firefox/api/1.2/search/Español

API 1.3 URL Search: FAIL
https://preview.addons.mozilla.org/en-US/firefox/api/1.3/search/Español

Live HTTP Headers details:

https://preview.addons.mozilla.org/en-US/firefox/api/1.2/search/Espa%C3%B1ol
GET /en-US/firefox/api/1.2/search/Espa%C3%B1ol HTTP/1.1
Host: preview.addons.mozilla.org
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.18) Gecko/2010020220 Firefox/3.0.18 (.NET CLR 3.5.30729) FBSMTWB
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Cookie: __utma=164683759.936129025.1268824573.1268907600.1268913053.6; __utmz=164683759.1268907039.4.2.utmccn=(referral)|utmcsr=bugzilla.mozilla.org|utmcct=/show_bug.cgi|utmcmd=referral; s_vsn_mozillapreviewaddonsorg_1=7526061220074; __utmv=164683759.Loggedout; dloadday=59.165.94.11.1268833860907372; __utmb=164683759; __utmc=164683759; s_cc=true; s_sq=%5B%5BB%5D%5D; amo_home_promo_seen=4

HTTP/1.1 500 INTERNAL SERVER ERROR
Server: Apache
Vary: Cookie, Accept-Encoding
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip
Date: Thu, 18 Mar 2010 11:57:06 GMT
Via: Moz-Cache-zlb03
Connection: close
X-Cache-Info: not cacheable; response code not cacheable


Note:
PASS: https://preview.addons.mozilla.org/en-US/firefox/search?q=Español&cat=all
PASS: API 1.2: searching in text field with "Español"

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551991
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.