Invalid arc() call in scrollbar crashes editor

RESOLVED FIXED in 0.7.1

Status

P1
blocker
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: pcwalton, Assigned: pcwalton)

Tracking

Trunk
0.7.1

Details

(Assignee)

Description

9 years ago
Since updating SproutCore, a scrollbar painting bug has appeared that makes the editor unusable. Occurs in both desktop and embedded builds.

Firebug displays the following message: An invalid or illegal string was specified" code: "12
(Assignee)

Comment 1

9 years ago
This seems to be caused by some SproutCore changes: for some reason, SproutCore ScrollViews are now setting the 'maximum' property to 0, causing all calculations that depend on it to fail (in this case, handleDistance is defined with a formula that includes 'maximum' as the denominator, resulting in a NaN).

Will revert to a previous SproutCore and will cherry-pick the relevant style changes instead of pulling from master, since there's no time to fix this before 0.7 needs to be released.
Assignee: nobody → pwalton
Status: NEW → ASSIGNED
Target Milestone: --- → 0.7.1
Version: 0.7.0 → Trunk
(Assignee)

Comment 2

9 years ago
This is caused by the changed scroll bar API in SproutCore. The problematic upstream git commit is cc44aa8915149eda18dd4c7f32c39d58224a468f. Reverted for now.

Marking this bug as fixed; updating the scroll bar to the new API is bug 553724.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.