Addressbook not migrated

VERIFIED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
P2
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Suresh Duddi (gone), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++] fix in hand)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Here is some info for you. The only wierd thing is that I have named my
addressbook dp-abook in 4.* rather than the default name.

I deleted .mozilla and did ./netscape -installer on beta3 bits. Here is how my
.mozilla/dp looks like:

% ls -l dp-*

-rw-r--r--   1 dp       wheel      933888 Oct  4 12:38 dp-abook-old.na2
-rw-rw-r--   1 dp       wheel       82795 Oct  4 12:38 dp-abook.ldif
-rw-r--r--   1 dp       wheel     1130496 Oct  4 12:38 dp-abook.na2
% grep pab prefs.js

user_pref("ldap_2.servers.pab.csid", "iso-8859-1");
user_pref("ldap_2.servers.pab.filename", "dp-abook.na2");
user_pref("ldap_2.servers.pab.locale", "C");
user_pref("ldap_2.servers.pab.replication.lastChangeNumber", 0);
user_pref("mail.imap.server.nsmail-2.capability", 31551);
user_pref("mail.server.server1.capability", 31551);
% ls -l abook*

-rw-r--r--   1 dp       wheel       97176 Oct  4 12:38 abook.nab
-rw-rw-r--   1 dp       wheel      393216 Oct  4 12:38 abookPAB.na2

Looks like the ldif file was generated alright. And even the addressbook was
migrated ok. Why is there a abookPAB.na2 It is never referenced by the pref.
There is an old abookPAB.na2 left over in my 4.* profile directory that is never
used. Could that haves caused it.
(Reporter)

Comment 1

18 years ago
Marking rtm. This is more complicated by the fact that addressbook import
doesn't work.
Keywords: rtm
egads, addressbook import doesn't work?  is there a bug on that?

Comment 3

18 years ago
Seth, AB import bug is 52086.
QA Contact: esther → suresh
accepting.  investigating.
hmm, I'm not able to reproduce this.  I'll go debug on dp's machine to see
what's going on.
Status: NEW → ASSIGNED

Comment 6

18 years ago
Seth, I'm working on bug 50584 which may not related to this bug.  Just 
let you know in case they are related.
ok, I've got dp's .netscape directory, and I'm able to reproduce this.

investigating.

Comment 8

18 years ago
marking [rtm need info]  If you figure out what's causing it before fixing it, 
can you update the bug.  If it's something rare we may not want to proceed.

Whiteboard: [rtm need info]
ok, I have a fix.  the problem is once we fail to upgrade a 4.x addressbook,
we'll never succeed after that since we aren't resetting m_status.

dp has multiple address books, and we failed on an early one, so we failed to
migrate the rest of them.

it's a simple one line fix.

I'll attach the patch.

r=bienvenu
sr=mscott
Whiteboard: [rtm need info] → [rtm+] fix in hand

Comment 11

18 years ago
changing priority.
Priority: P3 → P2

Comment 12

18 years ago
marking rtm++
Whiteboard: [rtm+] fix in hand → [rtm++] fix in hand
fix checked in on the branch and the tip.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
Verified on today's linux branch build. 
Keywords: vtrunk

Updated

18 years ago
QA Contact: suresh → pmock
Per Suresh's comments, marking VERIFIED.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.