All users were logged out of Bugzilla on October 13th, 2018

refetching image from cache/net on saving after clearing cache

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: eugene, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120413])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Description would be similar to the #120809, but a little different.
Shortly, Firefox won't save an image which I see in a tab, but which has been deleted both from the server (no longer available by the URL) and from the cache (e.g. opening that URL in another tab to see the 404 error).

Reproducible: Always

Steps to Reproduce:
Way to reproduce needs one to have access to a server where one can store files.
1. upload an image to server;
2. open two tabs with the same URL pointing to the image you've uploaded;
3. delete image file from server;
4. in the first tab press ctrl+f5 to reload and clear cache (it will produce a 404-error page);
5. in the second tab right click the image and choose "Save image as".
Actual Results:  
This will produce a file containing the server response (like the one we see in the first tab), instead of the image I actually see in the tab.

Expected Results:  
Obvious: the image I see should've been saved instead of trying to get it from cache/network.

I put severity level to critical, because I could not save the image from the web which was deleted from web and from cache so it caused me to lose data.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe
> mode? If not, please close. These links can help you in your testing.

Still the same in FF 3.6.13 [Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13] both in regular and safe modes.
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> You can also try to reproduce in Firefox 4 Beta 8 or later, there are many
> improvements in the new version,

Tried out the beta -- no changes in behavior described.

Updated

8 years ago
Whiteboard: [CLOSEME 2011-1-30]
Version: unspecified → Trunk
cant reproduce on latest build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120413]
You need to log in before you can comment on or make changes to this bug.