Deleting a message open in a tab doesn't close the tab

RESOLVED DUPLICATE of bug 531534

Status

Thunderbird
Toolbars and Tabs
--
minor
RESOLVED DUPLICATE of bug 531534
8 years ago
8 years ago

People

(Reporter: A. Logan Murray, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1036 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

When the delete button is clicked for a mail message open in a tab, the tab "navigates" to the next message in the folder, rather than closing the tab as would be intuitive with the process of deletion, and somewhat defeating the tabbing metaphor.

Reproducible: Always

Steps to Reproduce:
1. Open a message in a new tab.
2. Click the delete button for that message in the tab pane.
Actual Results:  
The tab navigates to the next message in the (no longer visible) folder from whence it came.

Expected Results:  
Intuitively, the tab should close and the last-focused tab should become foremost.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531534
You need to log in before you can comment on or make changes to this bug.