If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

fool.com article list is drawn at bottom of page, not right side of page.

VERIFIED INVALID

Status

()

Core
Layout: Tables
P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: cpeterso, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Looks like a table problem. The large table column is being drawn at underneath
the first column?

Updated

19 years ago
Assignee: troy → karnaze
Component: Layout → HTMLTables

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6

Comment 1

19 years ago
Moving to M8.

Updated

19 years ago
Whiteboard: [MAKINGTEST] 3jrgm --- may also be a client sniff

Comment 2

19 years ago
Created attachment 560 [details]
www.fool.com as served to 4.5 ua -- for standard comparison

Updated

19 years ago
Blocks: 3688
Whiteboard: [MAKINGTEST] 3jrgm --- may also be a client sniff → can't make simpler test; problem w page is layout of floated tables

Comment 3

19 years ago
'fool.com' is serving different content to 5.0 and 4.5. I've
attached the 4.5 content to this page for a consistent point of
comparison; the attachment does demonstrate the reported 'reflow of
tables' problem. (jun23 win95 viewer).  Marking that bug #3688 '[META]
content site userAgent sniffers don't respect mozilla/5.0 user agent'
has a dependency on this bug.

Comment 4

19 years ago
Simplifying the HTML tends to eliminate the problem, so I can't make
a simple example.

The gross structure of the page is composed of seven, self-contained,
independent (non-nested) tables:

 <table width=600>
 <table width=600>
 <table width=600>
 <table width=120 align=left height=1080>            ** floater
 <table width=350 align=left height=1060>            ** floater
 <table width=130 align=left height=1060 valign=top> ** floater
 <table width=598>

which should layout as:

+-TABLE-600px------------------------------------------+
+-TABLE-600px------------------------------------------+
+-TABLE-600px------------------------------------------+
+-TABLE-120px-+ +-TABLE---------350px--+ +-TABLE-130px-+
+-TABLE-598px------------------------------------------+

 What happens is that, as stated previously, the 350px and 130px get
reflowed below the 120px table. Note that these two tables are
sometimes loaded into the correct position; however, usually, waving
the mouse over the <a href>s on the page for a while can get the two
tables to suddenly jump to their new location (win95 jun23 viewer).

 So, the tables themselves are structurally OK; the problem is with
the layout of the floated tables.

Comment 5

19 years ago
This issue still occurs in the June 30th builds (Mac, Win 95, Linux)

Comment 6

19 years ago
Moving to M9.

Updated

18 years ago
Whiteboard: can't make simpler test; problem w page is layout of floated tables → [MAKINGTEST] michael@dayah.com

Updated

18 years ago
Target Milestone: M9 → M10

Comment 7

18 years ago
Moving to M10.

Comment 8

18 years ago
Created attachment 1460 [details]
testcase

Updated

18 years ago
Whiteboard: [MAKINGTEST] michael@dayah.com → [TESTCASE]

Comment 9

18 years ago
*** Bug 14029 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M10 → M11

Comment 10

18 years ago
Spoke to karnaze during bug triage today.  Moving to M11.  Not an M10 blocker.

Updated

18 years ago
Assignee: karnaze → kipp
Status: ASSIGNED → NEW

Comment 11

18 years ago
The url and 1st attachment look ok. Resizing the 2nd attachment smaller gives
different behavior than Nav4.6 and involves floating tables. Kipp, you can
decide if this is compatibility bug.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11 → M17

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 12

18 years ago
This behavior is correct and in conformance with css2 desired behavior with
floaters. Unlike navigator where content will always be placed next to a
floater, even if that content fits, css2 defines a collection of rules that
prevent overlap of content with floaters and floaters with other floaters.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 13

18 years ago
Based on Kipp's comments, marking as verified invalid.
*** Bug 17360 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.