SUMO can't import data from sumotools as a result of bug 549153

RESOLVED FIXED

Status

support.mozilla.org
General
--
critical
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Cww, Assigned: zzxc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
SUMO automatically imports some JSON data from sumotools (located at http://dm-sumotools01.mozilla.org/exports/export.txt)  This doesn't work now (probably as a result of the fix in bug 549153)

See bug 514055 for another time we had to fix this... (has lots of technical details).

SUMO devs: you should probably take a look at this first in case it's something on the SUMO side, but I suspect we'll need IT.
-->1.5.4
This is preventing the l10n dashboard from being updated.
Target Milestone: --- → 1.5.4
(Reporter)

Comment 2

8 years ago
Moving to serverops, can we get any insights from IT?
Assignee: nobody → server-ops
Component: Knowledge Base Software → Server Operations
Product: support.mozilla.com → mozilla.org
QA Contact: kb-software → mrz
Target Milestone: 1.5.4 → ---
Version: unspecified → other
From where are you guys trying to access this?
Assignee: server-ops → shyam
Alright, the issue is probably in your .htaccess rules :

[shyam@boris ~]$ curl -v -I -L http://dm-sumotools01.mozilla.org/exports/export.txt

* Issue another request to this URL: 'http://dm-sumotools01.mozilla.org/exports/export.txt'
* About to connect() to dm-sumotools01.mozilla.org port 80
*   Trying 10.2.74.133... connected
* Connected to dm-sumotools01.mozilla.org (10.2.74.133) port 80
> HEAD /exports/export.txt HTTP/1.1
> User-Agent: curl/7.15.5 (i386-redhat-linux-gnu) libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5
> Host: dm-sumotools01.mozilla.org
> Accept: */*
> 
< HTTP/1.1 302 Found
HTTP/1.1 302 Found
< Date: Thu, 25 Mar 2010 11:49:21 GMT
Date: Thu, 25 Mar 2010 11:49:21 GMT
< Server: Apache/2.2.3 (Red Hat)
Server: Apache/2.2.3 (Red Hat)
< Location: http://dm-sumotools01.mozilla.org/exports/export.txt
Location: http://dm-sumotools01.mozilla.org/exports/export.txt
< Connection: close
Connection: close
< Content-Type: text/html; charset=iso-8859-1
Content-Type: text/html; charset=iso-8859-1

* Closing connection #0
* Maximum (50) redirects followed
curl: (47) Maximum (50) redirects followed

So it's going into an infinite redirect loop. I don't see any auth on exports and the timestamps show the cron last ran on Monday, 22nd.
(Reporter)

Comment 5

8 years ago
I don't remember changing the htaccess... Matthew, James?

Comment 6

8 years ago
This bug blocks us from tracking metrics for one of our Q2 goals. => Critical
Severity: normal → critical
(Assignee)

Comment 7

8 years ago
This was being caused by line 19 of /var/www/html/.htaccess, which were the old
https->http redirection rules.  I fixed it by running htaccess.sh to pick up
the latest .htaccess from subversion.
Assignee: shyam → bugs
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Component: Server Operations → General
Product: mozilla.org → support.mozilla.com
QA Contact: mrz → general
Version: other → unspecified
You need to log in before you can comment on or make changes to this bug.