If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

textarea resizer styling is not always consistent

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
P2
normal
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: u88484, Assigned: Neil Deakin)

Tracking

({polish})

Trunk
x86
Windows 7
polish
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 433682 [details]
Screenshot

The style of the resizer of a textarea is not always consistent.  Look at a couple different textarea resizers and notice how some look like 3-2-1 dots and others look like someone had been tapping a pen on a piece of paper. 

Screenshot is during the same browsing session, using windows 7 so drag a tab to a new window and did the little drag the windows to the side to keep both in focus at the same time thing.
(Reporter)

Updated

8 years ago
Summary: Style of the resizer of textarea is not always consistent → textarea resizer styling is not always consistent

Updated

8 years ago
Component: Theme → Layout: Form Controls
Product: Firefox → Core
QA Contact: theme → layout.form-controls
blocking2.0: --- → ?
(Assignee)

Comment 1

8 years ago
Created attachment 434049 [details] [diff] [review]
inherit -moz-resize instead of the special check

Looks like the 'placeholder' anonymous div is creating a scrollframe as well. Instead, we'll just inherit -moz-resize on the one scrollframe and disable it on the placeholder.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #434049 - Flags: review?(dbaron)
Comment on attachment 434049 [details] [diff] [review]
inherit -moz-resize instead of the special check

r=dbaron

If you want, feel free to also change the code to cache either (a) a pointer to the |const nsStyleDisplay*| or (b) the value of its mResize rather than calling mOuter->GetStyleDisplay() multiple times.  (GetStyleDisplay() isn't quite as trivial as you might think, although it should never be too bad the second time.)
Attachment #434049 - Flags: review?(dbaron) → review+
(Assignee)

Comment 3

8 years ago
http://hg.mozilla.org/mozilla-central/rev/ca874c58573b
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
Haven't seen the blurry icon today so verifying fixed using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100324 Minefield/3.7a4pre
Status: RESOLVED → VERIFIED
blocking2.0: ? → final+
Priority: -- → P2
Duplicate of this bug: 554763
Depends on: 624425
No longer depends on: 624425
You need to log in before you can comment on or make changes to this bug.