entering private browsing aborts active downloads

RESOLVED DUPLICATE of bug 541739

Status

()

RESOLVED DUPLICATE of bug 541739
9 years ago
6 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

If you have an active download when you enter private browsing mode, that download just disappears, and I think it gets aborted.  Once you leave private browsing, you get a "xxx could not be saved, because the file could not be accessed" error (or similar, the bogus error when for some reason the .part file can't be renamed to the main file).

We should really do something smarter with active downloads, especially since they're basically killed off without the ability to resume.
Bug 541739 related?

Comment 2

9 years ago
Do you have a sample URL on which you've seen this problem?  Downloads should be resumed after you leave the private browsing mode.

Comment 3

9 years ago
To me , this is really not good , download manager and private mode should not have any relation...
Thats why IE, Chrome and Opera have isolated private mode (IE isolates downloads), in Opera we have new private tab , and in Chrome  we have Incognito window , hence downloads are not affected. Firefox should follow same pattern to get more ppl migrating from above mentioned browsers to Firefox

Comment 4

9 years ago
(In reply to comment #2)
> Do you have a sample URL on which you've seen this problem?  Downloads should
> be resumed after you leave the private browsing mode.

He is referring to downloads from say Rapidshare etc , which are NOT resumable

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541739
You need to log in before you can comment on or make changes to this bug.