infinite loop, warnings seen

VERIFIED DUPLICATE of bug 53836

Status

P2
normal
VERIFIED DUPLICATE of bug 53836
18 years ago
14 years ago

People

(Reporter: slogan, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm need info])

(Reporter)

Description

18 years ago
It is somewhat hard to predict an intermittent, but the warning message is 
enough perhaps to suggest the fix:

<syd> JavaScript strict warning:
<syd> chrome://navigator/content/navigator.js line 1970: reference to undefined 
proper
<syd> ty window._content.HTTPIndex

This is being seen in the commercial ns pr3 branch but I assume it is also a 
problem in mozilla.
(Reporter)

Comment 1

18 years ago
nominating rtm because infinite loops are uncool, and perhaps the strict warning 
message will help this bug get resolved quickly.
Keywords: rtm

Comment 2

18 years ago
Matt, does this really cause a problem, i.e. a bug or a lockup, anywhere?
Assignee: don → matt
Priority: P3 → P2
Whiteboard: [rtm need info]

Comment 3

18 years ago
I don't see this as an infinite loop but I do see this error almost everytime 
that the browser is loading a page.

This code seems to be here for pass default charset to directory viewer for bug 
http://bugzilla.mozilla.org/show_bug.cgi?id=28787

It seems that window._content.HTTPIndex is not a property.

Giving to nhotta who put this code in there
Assignee: matt → nhotta
(Assignee)

Comment 4

18 years ago
This is a dup of bug 53836 the patch is attached there.
As I mentioned in 53836, the number of warning is reduced when bug 51211 is fixed.
And bug 51211 was actually checked in and fixed today.

Comment 5

18 years ago
shouldn't this bug stay open for the infinite loop problem? that's way more 
serious than some JS warnings.
(Assignee)

Comment 6

18 years ago
Bug 51211 was fixed yesterday. Using today's branch debug build, I only see the
warning once per a page load, so no looping behavior.
(Assignee)

Comment 7

18 years ago
So the remaining issue is a dup of bug 53836 and I don't think that's rtm.



*** This bug has been marked as a duplicate of 53836 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.