Closed Bug 553984 Opened 12 years ago Closed 12 years ago

JM: "Assertion failure: ops[idx].stackDepth == stackDepth, at ../methodjit/BytecodeAnalyzer.cpp"

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 553781

People

(Reporter: gkw, Unassigned)

References

Details

(Keywords: assertion, regression, testcase)

(function() {
  do {
    try {
      return
    }
    catch(x if (c)) {
      return
    } (x)
  } while (x)
})()

asserts js debug shell on JM tip with -m at Assertion failure: ops[idx].stackDepth == stackDepth, at ../methodjit/BytecodeAnalyzer.cpp:57
Checked in this test case.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553781
A testcase for this bug was already added in the original bug (bug 553781).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.