-moz-transform is not applied to the options in a dropdown select

RESOLVED DUPLICATE of bug 455164

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 455164
8 years ago
3 years ago

People

(Reporter: ivan, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.22.7 (KHTML, like Gecko) Version/4.0.5 Safari/531.22.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100321 Minefield/3.7a4pre

When a size 1 SELECT (i.e. a dropdown) is placed in an element that has -moz-transform applied, the options do not have the transform applied to them. i.e. the popup is displayed where it would have been had there been no transform applied.

However, mouse position detection appears to be attempting to factor in the transform. The result is that the options cannot be selected with the mouse - except where the area that the options should be overlaps with the area that they actually are. Then it is possible to select an option by clicking in the area it should be if the transform had been applied.

Confused? Well try the attached sample and it should make sense.

Reproducible: Always

Steps to Reproduce:
1. Attempt to select an option in the the attached sample.




Webkit and IE don't handle this very well either. Neither applies the transform (although IE does a better job of positioning the dropdown somewhere appropriate) but both are able to select an option.
(Reporter)

Comment 1

8 years ago
Created attachment 433891 [details]
Sample page that demonstrates the issue
Component: General → Style System (CSS)
Keywords: testcase
Product: Firefox → Core
QA Contact: general → style-system
Status: UNCONFIRMED → NEW
Component: Style System (CSS) → Layout: Form Controls
Ever confirmed: true
QA Contact: style-system → layout.form-controls
('rotate' is covered by bug 455164)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455170
Duplicate of bug: 455164
You need to log in before you can comment on or make changes to this bug.