[10.5] Crash in [@ alphaProviderGetBytes ] while dragging image to finder

RESOLVED DUPLICATE of bug 529910

Status

()

Core
Widget: Cocoa
--
critical
RESOLVED DUPLICATE of bug 529910
8 years ago
7 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

8 years ago
Seen while running Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.3a4pre) Gecko/20100321 Minefield/3.7a4pre

STR:
1. Load site in URL
2. Drag image to finder
3. Crash 100%

Unable to reproduce on Intel 10.6. Currently this is the #5 top crash on the trunk.
(Reporter)

Comment 1

8 years ago
My crash report: http://crash-stats.mozilla.com/report/index/7a6ac5da-18bb-43a9-aa72-a9b2e2100322

Frame  	Module  	Signature [Expand]  	Source
0 	@0xffff8b04 	
1 	ImageIO 	alphaProviderGetBytes 	
2 	ImageIO 	writeOne 	
3 	ImageIO 	_CGImagePluginWriteTIFF 	
4 	ImageIO 	CGImageDestinationFinalize 	
5 	XUL 	nsClipboard::PasteboardDictFromTransferable 	widget/src/cocoa/nsClipboard.mm:467
6 	XUL 	SetUpDragClipboard 	widget/src/cocoa/nsDragService.mm:123
7 	XUL 	nsDragService::InvokeDragSession 	widget/src/cocoa/nsDragService.mm:265
8 	XUL 	nsEventStateManager::DoDefaultDragStart 	content/events/src/nsEventStateManager.cpp:2238
9 	XUL 	nsEventStateManager::GenerateDragGesture 	content/events/src/nsEventStateManager.cpp:1996
10 	XUL 	nsEventStateManager::PreHandleEvent 	content/events/src/nsEventStateManager.cpp:1123
11 	XUL 	PresShell::HandleEventInternal 	dom/base/nsPIDOMWindow.h:6422
12 	XUL 	PresShell::HandlePositionedEvent 	dom/base/nsPIDOMWindow.h:6278
13 	XUL 	PresShell::HandleEvent 	layout/style/nsRuleNode.h:6141
14 	XUL 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1074
15 	XUL 	HandleEvent 	view/src/nsView.cpp:160
16 	XUL 	nsChildView::DispatchEvent 	widget/src/cocoa/nsChildView.mm:1768
17 	XUL 	nsChildView::DispatchWindowEvent 	widget/src/cocoa/nsChildView.mm:1776
18 	XUL 	-[ChildView mouseDragged:] 	widget/src/cocoa/nsChildView.mm:3281
19 	AppKit 	-[NSWindow sendEvent:] 	
20 	XUL 	-[ToolbarWindow sendEvent:] 	widget/src/cocoa/nsCocoaWindow.mm:2223
21 	AppKit 	-[NSApplication sendEvent:] 	
22 	AppKit 	-[NSApplication run] 	
23 	XUL 	nsAppShell::Run 	widget/src/cocoa/nsAppShell.mm:863
24 	XUL 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:182
25 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3548
26 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:158
27 	firefox-bin 	firefox-bin@0xa70
> 2. Drag image to finder

What does this mean?
(Reporter)

Comment 3

8 years ago
Sorry I should have been more clear. I basically placed my mouse over the image and then dragged it to the Finder Icon in the dock. I hardly can move it all before I crash.

The difference I see using 10.6 is that I actually see a "ghost" image of the thing I am dragging while I drag it to the dock. I do not see that using 10.5 PPC.
This is another variation of bug 529910.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529910
(Assignee)

Updated

7 years ago
Crash Signature: [@ alphaProviderGetBytes ]
You need to log in before you can comment on or make changes to this bug.