Searching history with high CPU load conflicts with Tablet PC input

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Arik Raffael Funke, Unassigned)

Tracking

({perf})

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

When typing in the location bar, FF searches in the background the history. The CPU load on my machine is 100% during these searches.

If the input is made with a traditional keyboard this is no problem, but it conflicts with on-screen keyboards, e.g. on tablet computers, and Windows Text Services Framework (TSF).

On-screen keyboards become VERY sluggish and are almost unusable if searching history is enabled. This could probably be avoided at least for TSF without much hassle by better management of process priorities of FF with respect to TSF processes.

See instructions on how to enable TSF in FF by its author on:
http://www.gottabemobile.com/forum/general-software/6724-gesso-firefox-add-still-being-developed.html

Reproducible: Always

Updated

7 years ago
Version: unspecified → 3.6 Branch
Can you please check if Firefox 4.0 improves the situation?
(Reporter)

Comment 2

7 years ago
Given that this is not flagged blocking or wanted for the next release, would it be ok to wait for the release of FF 4.0 or would it help if this was tested against the RC?
(Reporter)

Comment 3

7 years ago
@mak:

I just tested with FF4.0. There appears to be no change in behaviour at all. The on-screen keyboard is still impossible to use on tablet computers due to the high processor load FF incurs.

Comment 4

3 years ago
Arik, there have been some fixes to TSF in recent years.

Do you still see this problem?
Flags: needinfo?(arik)
Keywords: perf
Whiteboard: [closeme 2014-11-15]
(Reporter)

Comment 5

3 years ago
Wayne, I no longer own a PC with TSF and thus can no longer confirm this bug.

Closing it would be ok with me. Many thanks.
Flags: needinfo?(arik)

Comment 6

3 years ago
perhaps m_kato or alice can test
Flags: needinfo?(m_kato)
Flags: needinfo?(alice0775)

Comment 7

3 years ago
I do not have tablet PC.
Flags: needinfo?(alice0775)
I cannot reproduce this on Windows 8.1 tablet.

Although reporter set TSF=true, we already turn on TSF on Nightly.  So if this still occurs by TSF, all Nightly users will hit this.  But no report on Nightly now.
Flags: needinfo?(m_kato)

Comment 9

3 years ago
Thanks for testing. Let's call this WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2014-11-15]
You need to log in before you can comment on or make changes to this bug.