If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 3.6.2 won't install

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Ken Michael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Trying to install Firefox 3.6.2 fails for lack of administrator privileges when being installed by the only administrator.  No option to provide authentication.

Reproducible: Always

Steps to Reproduce:
1. Try to copy Firefox from .dmg file to Applications folder.
2. Window opens saying an older version exists.
3. Click on replace button.
4. Window opens saying operation cannot be completed because user lacks administrator privileges.  No option to provide admin authentication.
Actual Results:  
Upgrade fails

Expected Results:  
Upgrade installed

Comment 1

8 years ago
The copy process is done by the operating system, not by Firefox (there's no install program at all). You really need to ensure that you have write permissions on that folder. You can try removing the folder manually for instance before you copy the new version (your profile will not be harmed).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Ken, you were not running as administrator?
You need to log in before you can comment on or make changes to this bug.