Wrong permissions of installed files causes problems in the open/save dialog on Windows [caused by Comodo Internet Security]

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
3 years ago

People

(Reporter: katillac, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

This has been an ongoing problem through at least the past three updates. When I use the right-click context menu in Firefox to save a file (eg, a .gif or .jpg file), I'm able to save the file to an existing directory, but if I create a new directory, I've learned from others with this same issue that once I create the new directory, I have to refresh the window via right-click context menu or F5. Then, I have to rename the folder, then refresh again for it to show the new directory name.
Other major apps running: Comodo Internet Security, Spybot Search & Destroy (background only).
Also like many others, I am unable to drag images from my screen to tabs on my taskbar. In the past, I was able to drag to Windows Explorer, Paint Shop Pro, or to an email in progress (Outlook Express), but after an update about six months ago, since then I have been unable to do this.

Please, any help with either issue is appreciated.

Reproducible: Always

Steps to Reproduce:
1. Right-click over a graphic, select Save Image As
2. Save item box will pop up. Click on the icon to create new folder.
3. New folder will not show. Refresh screen to make it show.
4. New folder now will have the name "New Folder." Click on it to rename it.
5. Refresh screen yet again to show the new folder name.
6. Double-click on the folder icon next to the newly-named new folder to open it.

Actual Results:  
File saved, but my soul is still in limbo.

Expected Results:  
The software *should* have allowed new folder creation in which the folder can be given a name, hit enter and voila, fresh new folder with a new name, ready to place files in.

Banging my head on my desk does not help, but giving my screen the middle finger makes me feel a little better and at least a little more willing to continue using Firefox instead of trying an alternative.
Does the same happen in Safe Mode (http://support.mozilla.com/kb/Safe+Mode) or even in a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles)?
Component: Menus → General
QA Contact: menus → general
(Reporter)

Comment 2

9 years ago
I currently am using safe mode. I opened a new tab to Google and used their logo as a test download. While in the save file box, I did manage to create and name a new directory without going the extra steps. In safe mode, I also am able to drag from my Firefox screen onto the desktop, in Windows Explorer, and even into another window of Firefox or MSIE. Yeah, I even checked that one.

So, everything works like it should when I'm in safe mode. What's my next step?
You should go through your installed add-ons and disable those step by step. Looks like that an extension is causing this problem.
(Reporter)

Comment 4

9 years ago
Which addons? The ones in Firefox? In the past, I've disabled all addons and plugins and nothing changed. I will try that again, just to be sure.
(Reporter)

Comment 5

9 years ago
I disabled all addons AND plugins and the problem still exists. While saving a file, I tried creating a new directory and again, I have to refresh the window for the folder to show, then rename the folder, refresh, click on folder... lather, rinse, repeat. I'm told by a few friends that they have the same problem in Firefox.
Could you please test under another windows user account if the problem is there visible too? I wonder if any Windows settings come into play here.
(Reporter)

Comment 7

9 years ago
Hi, I created a fresh user account and the problem exists there, too. No drag and drop to the taskbar and no creating new folders from within Firefox without having to F5, rename, etc. I also experienced problems getting my firewall and AV to load (Comodo), so I went back to my main account, gave the new account admin privileges, logged off, then back onto the temporary account, and tried to repeat the drag and drop, as well as the file save/create new directory. Still the same problem.

The weird thing is, this began not long ago, directly after a Firefox upgrade. I went back to check install logs for other programs installed around the same time; there was one, and I've gone as far as to killproc it and even uninstalled it, but that did not change anything.

In MSIE, I am able to perform any of those tasks, including drag and drop images to the taskbar. It will ask "Do you want to move or copy files from this zone?" but if I check okay, it will alow the download. I checked every setting possible in Internet Options from the Control Panel and I cannot find anything there. I do have drag and drop enabled there.
Do you remember when you have upgraded and from which version to which version? That would be very important for us to know. That way we can narrow down possible patches which could have raised this problem on some systems. Thanks.
(Reporter)

Comment 9

9 years ago
I tried to find any notes as to when this issue began, but can not. I'm fairly sure it was 3.5 something. I previously reported an error that affected the sound played in Windows when minimising a Firefox window, and I know it was around the same time. The sound issue was no longer present after upgrading to 3.6.x (sorry, again, I forget which one; I was just happy to have my silly minimise window sound back in Firefox).

I'm suspicious that this is another one of those "enhancements" that Micro$oft made to encourage people to stop using competitors' products. MSIE can bite me.
We still have older releases available on our FTP server. It would be fantastic if you could test major releases like Firefox 3.5, and Firefox 3.0 if both are showing the same behavior. Please create a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles) so you do not mess-up your daily one. Thanks!

ftp://ftp.mozilla.org/pub/firefox/releases/
(Reporter)

Comment 11

9 years ago
Well, that was interesting. I had to do some reading to learn how to run two versions of Firefox, either simultaneously or individually, but on the same computer, in different directories. I created a new barebones profile, then made copies of it and the default to another drive, just in case. I then downloaded Firefox 3.0 and installed it on another drive.

When I fired up Firefox 3.0, it loaded with all my addons (I forgot to use command line and have it point to the new barebones profile). My first thought was "great, now I have to set up another profile and remove all my addons" but this is where it gets interesting - I was able to run Firefox 3.0 *with* all my addons, and I was able to do everything like before:
1) I was able to drag images from my browser window onto any taskbar programme or open Windows Explorer instance/folder.
2) I was able to right-click, save image, create new directory *without* refreshing my screen to see it, rename the directory *without* having to refresh my screen.

So, in short, everything I want it to do works fine in Firefox 3.0, even with all my addons running (Colourful Tabs, FireShot, Foxclocks, FxIF, UnMHT, Java Quick Starter, and Weather Watcher Live). All that, and the darned thing still ran right. 

Just to be sure, I closed everything, then ran Firefox 3.0 from a command line, selecting the barebones (new) profile, which is the one that doesn't load any frills, right down to the default icons. No change in browser behaviour when it comes to saving files from right-click context, or by dragging images from my browser window to taskbar buttons. Not a single problem!

I'm glad to know that it looks like this is strictly a Firefox issue and not something else on my computer, but on the other hand, now we need to find out what it was that changed between Firefox 3.0 and 3.6 and hope we can work together to fix that.

I'm going to go ahead and leave v3.0 installed, but for security reasons, I'm going to continue using 3.6. I will be away on Wednesday (7 April) for minor surgery, but I'll be back on the 8th. Thank you for staying with me on this!

If needed, I can try another version between the two I have now. I just need to get my stuff together on how to set up quick launch icons/links for each version, and to have it load the proper profile for each. Personally, I'm game for setting up another version of Firefox, with either quick launch or menu links to each, with ways to open each with the profile of my choosing.
That's interesting! Thanks for that great start in regression testing. It's good to know that everything is fine with Firefox 3.0 and we do not have to obey any systems setting. Between Firefox 3.0 and 3.6 we have a huge amount of changes so I have to rely on your time and motivation to help us finding that problem. It will probably take a bit but at the end we will be successful and can fix that bug.

So as the next steps I would propose the following:
1. Run a test with Firefox 3.5
2. If Firefox 3.5 shows the problem please run a test with the latest Firefox 3.0.19
3. If Firefox 3.5 doesn't show that problem test with Firefox 3.5.9
4. If Firefox 3.5.9 shows the problem test builds between 3.5 and 3.5.9 (bisect the range to reach the target earlier)
5. If Firefox 3.5.9 doesn't show that problem we would have to continue with beta versions of Firefox 3.6
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 13

9 years ago
UPDATE:

I went through, installing then uninstalling 3.5, 3.0.19, 3.5.9, 3.6, 3.6 RC 2.exe, 3.6, and another instance of 3.6.3. All ran fine - I was able to drag and drop to my desktop and task bar, and I was able to create directories when saving files, without having to refresh the window each time.

I then copied my main installation on my C drive over to the same drive and directory name as I had others installed on my F drive (F:\Program Files\Mozilla Firefox\). I ran it with both the default (customised) profile and the barebones one I created earlier in this testing phase.

It ran fine. I then checked the folder properties of both installations on C and F drives. They were the same. I then compared file properties of firefox.exe on both drives. Ah-HAH! Eureka, we found the problem. This is a screen cap of the file permissions tabs from listing properties for both instances of firefox.exe:

http://i42.tinypic.com/108ibv4.jpg

I covered the server name in the leftmost (C drive) panel for security reasons, but it is easy to tell that the permissions on that file are VERY tight. The mystery to me is that I am logged in as owner/Administrator, yet it still will not allow me to drag and drop/create directories using Firefox.

I reckon at this point I need to search the Microsoft help site (I *hate* that) to see how to loosen the permissions. I tried changing them manually, while logged in as Administrator, yet it would not keep the changes.

If you or anyone else has any suggestions on how to remedy this, I'm all ears. If I can't wrangle the installation on my C drive to cooperate, I can always use the one on my F drive.

Wow. All this BS only to find out it's a permissions thing. The odd part is, this did not occur until around the time I upgraded to Firefox 3.5. The only other thing I can think of is it has to be associated with something else I installed around that time.

Thanks again for any help!
Wow, that's a really interesting thing you have discovered here. I will CC Robert Strong who has a good knowledge about Windows related problems. I wonder if this is a Windows bug and we suffer from it because of the wrong file permissions.
Summary: Saving files - create new directory issue → Wrong permissions of installed files causes problems in the open/save dialog on Windows
(In reply to comment #14)
> Wow, that's a really interesting thing you have discovered here. I will CC
> Robert Strong who has a good knowledge about Windows related problems. I wonder
> if this is a Windows bug and we suffer from it because of the wrong file
> permissions.

As usual I have CC'ed the wrong person. Correcting...
(Reporter)

Comment 16

9 years ago
As I hadn't seen anything here for the past nine days, I decided to do more research and experiment around with settings. Still, nothing. I did, however, find that if I try to drag and drop from MSIE 6 to my taskbar, it pops up a query box with the following: "Do you want to move or copy files to this zone?"

That led me to check my security settings, but I don't see how that would affect programs installed only on my C drive, but not the other drive which has the alternate installation of Firefox on it. I've exhausted my brain trying to figure this out, and comparing permissions on drives, directories, and down to files when comparing the Firefox on my C drive to that on another drive.

I just fired up MSIE 6 again to double check the create directory window while saving files. When I click on the create new folder icon, it creates the folder and allows me to rename it, without refreshing my screen. So, it appears that this particular issue is unique to Firefox when comparing between Firefox and MSIE.

I'm hoping that the "Do you want to move or copy files to this zone?" pop-up in MSIE when trying to drag and drop graphics from my browser window to my taskbar (to drop it into Internet Explorer) may provide additional clues to someone who knows more about all this than I do. Part of me is hoping that you'll find yet another one of those wonderful little "enhancements" that Microsoft provides with updates that work in their browser, but no one else's.
Duplicate of this bug: 491255
Kat, sorry for the delay in the reply but could you please give us the output from "cacls.exe firefox.exe"? I would have to see the exact permissions for each of the listed users. That would be really helpful to determine which part makes those problems. But something you can also try is to make updates to the permissions (to a copy of the exe file) so those are getting similar to the needed ones (right side of your screenshot). I wonder which of the limitations is causing this problem.
(Reporter)

Comment 19

8 years ago
Whew. It took me some trying to get the command correct. Silly me used "command" instead of "cmd" and I was having fits changing directories. Once I got into the proper directory and issued the command, here is the result:

C:\Program Files\Mozilla Firefox\firefox.exe BUILTIN\Administrators:F 

While I was at it, my curiosity kicked in and I issued the same command for the Firefox installation on another drive. Here is the result of that one:

F:\Program Files\Mozilla Firefox\firefox.exe Everyone:F

Okay, I can see why I'm able to do everything with the F drive installation of Firefox, but the "BUILTIN\Administrators" part goes over my head. I understand the F flag as being full permission.

If you need the results from my issuance of the cacls command from the root of C: for comparison, please let me know. I don't feel secure in posting it here if anyone can read it. I don't understand this and I'm feeling a little paranoid.

Thanks as always for your help!
kat
(In reply to comment #19)
> Whew. It took me some trying to get the command correct. Silly me used
> "command" instead of "cmd" and I was having fits changing directories. Once I
> got into the proper directory and issued the command, here is the result:
> 
> C:\Program Files\Mozilla Firefox\firefox.exe BUILTIN\Administrators:F 

That's a bit different to the output you have seen in comment 13 (http://i42.tinypic.com/108ibv4.jpg). Can you verify that the result you can see now ended up in the same behavior? I would need the complete output for all users/groups to check this myself.
(Reporter)

Comment 21

8 years ago
This is what it currently looks like:
http://i46.tinypic.com/16gbzfn.jpg
I tried it in a couple of variations but wasn't able to find a way to reproduce. Can you please send me the cacls output from c:\ and c:\program files? Also the user you are testing with has limited permissions, right?
(Reporter)

Comment 23

8 years ago
Henrik, I directed the results into two text files (I actually remembered that part from the old DOS days!) and emailed them to you. I apologise for using that method, but I'm not secure in pasting the full results of my directory structure and permissions here for anyone in the world to see.
kat
(Reporter)

Comment 24

8 years ago
Henrik, I'm not sure if you received the files I sent, but I've been needing to update this and I could not find the original link.

I recently had to do a major upgrade in my AV/firewall (Comodo Internet Security, now CIS Premium) and I momentarily forgot which installation of Firefox I was using. I used drag and drop and it worked, then realised I was using the "restricted" version - the original installation we were trying to figure out what was causing the problem. I have no reason to believe that the primary culprit here was my AV/firewall. The new upgrade of Comodo handles programs differently, and I'm able to drag and drop.

Shortly afterwards, I received upgrade notice for Firefox 3.6.3. After installing it, I was then able to make directories and name them without having to use F5 to refresh the box.

So, problems fixed! I hope that our experience with these bugs will be able to help others who also use Comodo AV and encounter the same problems.

I dearly appreciate all the time and effort you guys have spent in helping me!
Thanks Kat for the reply. Yes, I got your last email and I have also tried to reproduce it but wasn't lucky. I haven't had that much time the last weeks to do deeper testing. But as it turns out now, you have successfully identified the issue. It's great to hear and it will definitely help us in the future if similar problems will be reported.

Closing this bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Summary: Wrong permissions of installed files causes problems in the open/save dialog on Windows → Wrong permissions of installed files causes problems in the open/save dialog on Windows [caused by Comodo Internet Security]
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.