Cannot subscribe to shared IMAP folders (2 problems)

RESOLVED INCOMPLETE

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED INCOMPLETE
8 years ago
6 years ago

People

(Reporter: Philippp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol logs][closeme ?])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

Small workgroup, local IMAP server.
User Alice grants read (or editor) permissions to Bob on some of her folders, for instance her "Archives" folder.
Bob cannot subscribe to these folders: The checkmarks he places in the subscription dialog just have no effect, and have vanished when he opens the dialog again.

(In fact, problem #2, it takes a preliminary subscription of any of alices folders in webmail to make Alice visible in Bob's subscribe dialog at all, but that is the minor evil. Bob's frustrated admin has taken this additional step before.)

Reproducible: Always

Steps to Reproduce:
1. Two users on local IMAP server (I tried on Kerio Connect 7): Alice , Bob.
2. Alice has an "Archives" folder, as is created by default in TB after pressing the A key on a message.
3. Alice uses webmail to grant editor privileges for all domain users on her Archives folder.
4. Bob tries to subscribe to Alices' Archives folder.

Actual Results:  
Bob cannot subscribe to ~alice@domain.local/Archives.

Expected Results:  
Bob can subscribe to ~alice@domain.local/Archives.

The check mark in the subscription dialog has no effect, and has vanished when entering the dialog the next time. Upon start of TB, the folder seems to flash up in the folder tree, but instantly vanishes again. So I suspect that for some strange reason, the subscription is cancelled by TB upon startup.

Sometimes, doing the subscription in webmail also makes these folders subscribed in TB, and all seems well. From that time on, users can subscribe/unsubscribe them.
Sometimes (seemingly more probable with special folders like "Sent Items"), subscribing via webmail just makes the folder appear in the subscription dialog, but the user needs to additionally subscribe in TB.
(Reporter)

Comment 1

8 years ago
Created attachment 434234 [details]
IMAP log Bob trying to subscribe to ~alice@.../Archives/2009

Bob had successfully subscribed to Alices' Archives/2010 via webmail (see above).
In the meantime, Alice has created Archives/2009.
Bob tries to subscribe to that folder - his check mark keeps vanishing.
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Whiteboard: [has protocol logs]

Comment 2

6 years ago
Philippp, do you still see this problem?  If so then someone can have a look at the logs.

Comment 3

6 years ago
Philippp writes "the site with the Kerio server (where I saw these problems) has been sold to another company, so I do not have this environment any longer for testing etc."
Whiteboard: [has protocol logs] → [has protocol logs][closeme ?]
RESOLVED INCOMPLETE, then?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.