If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Drag-n-drop bookmarks does not save them.

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Ajai Khattri, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 FirePHP/0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 FirePHP/0.4

I used to be able to drag a URL to a folder on the bookmarks bar and save into a folder. This behavior has stopped working for some reason. If I click the folder, I see my bookmarks but if I use the organize bookmarks function, the new bookmarks I added are not there. I tried closing and restarting the browser and the bookmarks I added are gone. Maybe a file permissions problem?

Reproducible: Always

Steps to Reproduce:
1. Drag bookmark into a folder on the bookmarks bar.
2. Go into Bookmarks -> Organize bookmarks...
3. Check for the new bookmarks that were just added.
Actual Results:  
No new bookmarks have been added so they dont show up in the organizer but they DO show up in the folder I added them to (unless I restart the browser, then they disappear).

Expected Results:  
I should see my bookmarks, I should be able to see them in the organizer and they should persist across browser restarts.

Im attaching screenshots, showing how my bookmarks folder looked like. And a second showing what's shown in the organizer during the same session.
(Reporter)

Comment 1

8 years ago
Created attachment 434242 [details]
Bookmarks folder opened from the bookmarks bar.
(Reporter)

Comment 2

8 years ago
Created attachment 434243 [details]
Bookmarks organizer showing empty folder.
Have you first tried Safe Mode? http://support.mozilla.com/kb/Safe+Mode
it could indeed due to an extension conflict.
also, does the same work on 3.6.0?
do you see any error in the Error Console when you drag in the folder?
(Reporter)

Comment 6

8 years ago
Where do I enable the error console?
Tools / Error Console
(Reporter)

Comment 8

8 years ago
This is weird: I restarted in Safe Mode and I saw my bookmarks. Furthermore, I quit and restarted normally and the bookmarks are there. I dont know what fixed. I *did* upgrade to 3.6.2 before I filed this bug because I was still seeing the issue (The upgrade had problems overwriting some files so I wiped the app and started over).

Seems to be working now - guess you can close this ticket out.
some weird add-on compatibility issue i guess.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.