Closed Bug 554350 Opened 10 years ago Closed 9 years ago

jscntxt.h: warning C4273: js::MarkContext' : inconsistent dll linkage

Categories

(Core :: JavaScript Engine, defect)

x86
Windows Server 2003
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 624205
Tracking Status
blocking2.0 --- -
status2.0 --- wanted

People

(Reporter: sgautherie, Assigned: sayrer)

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269338520.1269345794.26989.gz&fulltext=1
WINNT 5.2 mozilla-central nightly on 2010/03/23 03:02:00
{
e:\builds\moz2_slave\mozilla-central-win32-nightly\build\js\src\jscntxt.h(707) : warning C4273: 'js_GetClassPrototype' : inconsistent dll linkage
        e:\builds\moz2_slave\mozilla-central-win32-nightly\build\js\src\jsobj.h(1035) : see previous definition of 'js_GetClassPrototype'
e:\builds\moz2_slave\mozilla-central-win32-nightly\build\js\src\jscntxt.h(1396) : warning C4273: 'js_TraceContext' : inconsistent dll linkage
        e:\builds\moz2_slave\mozilla-central-win32-nightly\build\js\src\jsgc.h(184) : see previous definition of 'js_TraceContext'
}
blocking2.0: --- → ?
Flags: in-testsuite-
Assignee: general → sayrer
blocking2.0: ? → beta1+
blocking2.0: beta1+ → beta2+
blocking2.0: beta2+ → betaN+
Any chance this can get some love as a persistent source of MSVC warning spam?
See also:
c:\mozbuild\mozilla-central\js\src\jscntxt.h(2412) : warning C4273: 'js::MarkContext' : inconsistent dll linkage
        c:\mozbuild\mozilla-central\js\src\jsgc.h(812) : see previous definition of 'MarkContext'

These warnings are scattered throughout during the build process.
The definitions in question are:

jsgc.h:
787 extern JS_REQUIRES_STACK JS_FRIEND_API(void)
788 MarkContext(JSTracer *trc, JSContext *acx);

jscntxt.h:
2461     friend void MarkContext(JSTracer *trc, JSContext *acx);
Also, the original warnings are no longer present.
Summary: jscntxt.h: 2 "warning C4273: 'js_*' : inconsistent dll linkage" → jscntxt.h: warning C4273: js::MarkContext' : inconsistent dll linkage
blocking2.0: betaN+ → -
status2.0: --- → wanted
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624205
V.Duplicate
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.