Crash in JS closing standalone mail window

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: mikepinkerton, Assigned: scottputterman)

Tracking

({crash})

Trunk
PowerPC
All
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Don't see this all the time, but I have seen it once in a while. Commercial
branch bits, 10/5/00.

Closing a standalone mail message window, crash with the following stack. Just
wanted to make sure this got filed. I didn't see this with PR3, which i used
extensively before updating to the current branch build.

 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  14BFBADC
  15C20C00    PPC  14BE6418  main+00130
  15C20BA0    PPC  14BE592C  main1(int, char**, nsISupports*)+0083C
  15C208F0    PPC  16D40E40  nsAppShellService::Run()+00018
  15C208B0    PPC  14883480  nsAppShell::Run()+00048
  15C20860    PPC  14883BBC  nsMacMessagePump::DoMessagePump()+0003C
  15C20810    PPC  148841AC  nsMacMessagePump::DispatchEvent(int,
EventRecord*)+0014C
  15C207C0    PPC  1489BD9C  Repeater::DoIdlers(const EventRecord&)+00030
  15C20780    PPC  1489C1DC  nsTimerPeriodical::IdleAction(const EventRecord&)+00014
  15C20740    PPC  1489C584  nsTimerPeriodical::FireNextReadyTimer()+0003C
  15C20700    PPC  1489C3A0
nsTimerPeriodical::FireAndReprimeTimer(nsTimerImpl*)+00094
  15C206B0    PPC  1489D098  nsTimerImpl::Fire()+00024
  15C20670    PPC  14A72770  nsGlobalWindow_RunTimeout(nsITimer*, void*)+00018
  15C20630    PPC  14A71C28  GlobalWindowImpl::RunTimeout(nsTimeoutImpl*)+002AC
  15C20370    PPC  14A4B72C  NS_NewScriptElement+02D48
  15C201C0    PPC  14A4D71C  nsJSContext::ScriptEvaluated(int)+0002C
  15C20180    PPC  14A710F0  GlobalWindowImpl::CloseWindow(nsISupports*)+0005C
  15C20120    PPC  14A6A308  GlobalWindowImpl::Close()+00080
  15C200B0    PPC  16D4F49C  nsChromeTreeOwner::Destroy()+00018
  15C20070    PPC  16D38468  nsWebShellWindow::Destroy()+00128
  15C1FFC0    PPC  16D54680  nsXULWindow::Destroy()+00240
  15C1FEC0    PPC  147D41F0  nsWebShell::Destroy()+00028
  15C1FE70    PPC  147B3744  nsDocShell::Destroy()+000F4
  15C1FE10    PPC  147B3D00  nsGetInterface::nsGetInterface(nsISupports*,
unsigned int*)+0CC6
0
  15C1FDD0    PPC  14B38DAC  nsCOMPtr_base::assign_with_AddRef(nsISupports*)+00048
  15C1FD90    PPC  1460AA68  DocumentViewerImpl::Release()+00040
  15C1FD50    PPC  1460B1EC  DocumentViewerImpl::~DocumentViewerImpl()+0032C
  15C1FC80    PPC  14B38D04  nsCOMPtr_base::~nsCOMPtr_base()+00030
  15C1FC40    PPC  142E1BD8  PresShell::Release()+00040
  15C1FC00    PPC  142E218C  PresShell::~PresShell()+00134
  15C1FBB0    PPC  14636238  FrameManager::Release()+00040
  15C1FB70    PPC  14636300  FrameManager::~FrameManager()+00078
  15C1FB00    PPC  145C8F3C  ViewportFrame::Destroy(nsIPresContext*)+0002C
  15C1FAC0    PPC  142BA380  nsContainerFrame::Destroy(nsIPresContext*)+00054
  15C1FA70    PPC  145EE8A8  nsFrameList::DestroyFrames(nsIPresContext*)+00048
  15C1FA20    PPC  145F3480  nsBoxFrame::Destroy(nsIPresContext*)+00098
  15C1F9B0    PPC  142BA380  nsContainerFrame::Destroy(nsIPresContext*)+00054
  15C1F960    PPC  145EE8A8  nsFrameList::DestroyFrames(nsIPresContext*)+00048
  15C1F910    PPC  145F3480  nsBoxFrame::Destroy(nsIPresContext*)+00098
  15C1F8A0    PPC  142BA380  nsContainerFrame::Destroy(nsIPresContext*)+00054
  15C1F850    PPC  145EE8A8  nsFrameList::DestroyFrames(nsIPresContext*)+00048
  15C1F800    PPC  145F3480  nsBoxFrame::Destroy(nsIPresContext*)+00098
  15C1F790    PPC  142BA380  nsContainerFrame::Destroy(nsIPresContext*)+00054
  15C1F740    PPC  145EE8A8  nsFrameList::DestroyFrames(nsIPresContext*)+00048
  15C1F6F0    PPC  142BA380  nsContainerFrame::Destroy(nsIPresContext*)+00054
  15C1F6A0    PPC  145EE8A8  nsFrameList::DestroyFrames(nsIPresContext*)+00048
  15C1F650    PPC  142D328C  nsFrame::Destroy(nsIPresContext*)+00120
  15C1F5E0    PPC  1451C198  nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame()+00038
  15C1F5A0    PPC  147D41F0  nsWebShell::Destroy()+00028
  15C1F550    PPC  147B3804  nsDocShell::Destroy()+001B4
  15C1F4F0    PPC  147B3908  nsGetInterface::nsGetInterface(nsISupports*,
unsigned int*)+0C86
8
  15C1F4B0    PPC  14B38DAC  nsCOMPtr_base::assign_with_AddRef(nsISupports*)+00048
  15C1F470    PPC  14A4A414  nsJSContext::Release()+00040
  15C1F430    PPC  14A4A1EC  nsJSContext::~nsJSContext()+00100
  15C1F3B0    PPC  1640E580  JS_DestroyContext+00010
  15C1F370    PPC  1641A168  js_DestroyContext+00160
  15C1F320    PPC  1642BB10  js_ForceGC+0003C
  15C1F2E0    PPC  1642BE24  js_GC+00208
  15C1F270    PPC  16462B40  JS_HashTableEnumerateEntries+0005C
  15C1F200    PPC  1642BA44  gc_root_marker+0003C
 Closing log

Comment 1

18 years ago
call stack looks like a timer fired which evaluated js which closed a window -
might be dupe of bug 50705
(Assignee)

Comment 2

18 years ago
is this still happening?
OS: All

Updated

18 years ago
Keywords: crash
(Reporter)

Comment 3

18 years ago
don't think i've seen this recently.
Based on Mike's comments and my own experiences, marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.