If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incremental reflow on image load makes floated table too wide

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: John Morrison, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Overview Description:
  I noticed this on a sun.com page. Mozilla's behaviour may be strictly
  correct but I haven't thought about it a great deal. It is however,
  different from legacy behaviour.

Steps to Reproduce:
1) Load the attached testcase and compare to nav4.x/IE5

Actual Results: Table with the image is not floated right

Expected Results: Table should be floated right (at least by 4xp rules)

Reproducibility: 100%

Build Date & Platform Bug Found:
  win2k 2000100509 MN6 branch build

Additional Information:

  The table places an 'align=right' on the outer table, but no
  width. The fixed width comes from the only cell, another table
  that specifies 'width=300'.

  The IMG replaced element is required to reproduce this behaviour,
  otherwise the same nested table will float right with width of 300.


<HTML>
<BODY>

<TABLE BORDER ALIGN="right"><TR><TD>
<TABLE BORDER WIDTH="300"><TR><TD>

  <IMG SRC="http://www.mozilla.org/newlayout/l.gif" ALIGN="LEFT" ALT="Java">

  <br clear="all">XML (Extensible Markup Language), is a universal
  syntax for describing &amp; structuring data independent from the
  application logic. J2EE deployment descriptors are expressed in XML.

</TD></TR></TABLE>
</TD></TR></TABLE>


<P>
XML, the Extensible Markup Language, is much more than just a
markup language. An XML page looks something like an HTML page, but
there the similarity ends.
</P>

</BODY>
</HTML>
(Reporter)

Comment 1

17 years ago
Created attachment 16299 [details]
testcase; nested table does not float
(Reporter)

Comment 2

17 years ago
Uh, interesting. The first time I load that attachment over the net, the table
is floated right. However, on a subsequent reload, it appears on the LHS of
the page. (The sun.com page, though, invariably brings the tables to the LHS).

Comment 3

17 years ago
Actually, the table IS floating.  If you load the test case in viewer and dump
frames, you'll see a placeholder frame that contains the outer table.
Placeholders are only created for floated (and positioned) elements.

But, the table is getting sized too wide, as wide as the window.  So it looks
like it's not floating, because it's pushing down all subsequent content.
Changing subject to reflect this.  It's probably a block bug, not a table bug.
I'll have to turn on some debugging code and check it out.  Very low probability
this could make it into rtm.
Status: NEW → ASSIGNED
Summary: Floated table with no explicit width fails to float. → Floated table too wide

Comment 4

17 years ago
Created attachment 16306 [details]
somewhat smaller test case, very similar to first attachment

Comment 5

17 years ago
actually, it looks like a table incremental reflow bug.  If you replace the
<IMG SRC="..."> in the test case with an <IMG> or <IMG Width=50 Height=50>, the
page lays out correctly.  The difference is in the test case, the image causes
an incremental reflow when the image finally loads from the net.  In the two
examples I've cited, there is no additional incremental reflow becaue the image
size is known.  About to attach another test case so you can see what I mean.

Updated

17 years ago
Summary: Floated table too wide → Incremental reflow on image load makes floated table too wide

Comment 6

17 years ago
Created attachment 16307 [details]
test case that works, same as above but Src attribute removed from IMG, replace with Width and Height

Comment 7

17 years ago
QA contact update
QA Contact: chrisd → amar

Comment 8

16 years ago
WFM Win98 2001080603, Amar could you please verify?

Thanks

Bernd
Keywords: testcase
(Reporter)

Comment 9

16 years ago
Yeah, WFM  on win2k 8/15 build. Marking as WORKSFORME, and if you just 
load the testcases on mac/linux/win32 or today's builds, and they are 
fine, then this is done.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
 Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.