[Edit Contributions Page] ambiguous error message is displayed while entering invalid values in suggested amount field

VERIFIED FIXED in 5.12.3

Status

P3
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: pratibha, Assigned: chenba)

Tracking

unspecified
5.12.3
x86
Windows XP

Details

(Whiteboard: [patch])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 434499 [details]
image shows the error message coming up with invalid input in suggested amount field

Steps:
1)Login to Developer account at: https://preview.addons.mozilla.org
2)Click My Account->My Add-ons links
3)Click on "Edit Add-on" link for one of the hosted add-on in your account
4)In Edit <add-on name> page: Click on "Manage Contributions"
5)Under "Asking for Contributions" section: Enter incorrect suggested amount
say example: abc
7)Click on "Update Contributions"

Result: Error message displayed with invalid input in Suggested amount field is "Should be a positive number between 0.00 and 99.99.".
This message is confusing, from the message it seems that not more than $99.99 should be given as Suggested Donation amount
Error message should be "Please enter a suggested amount less than $1000."
This bug is just a text change.
Assignee: nobody → chenba
Target Milestone: --- → 5.12.3
Summary: [Edit Contributions Page]ambiguous error message is displayed while entering invalid values in suggested amount field → [Edit Contributions Page] ambiguous error message is displayed while entering invalid values in suggested amount field
Priority: -- → P3
(Assignee)

Comment 3

8 years ago
Judging from the date of the bug and the vastly different contribution edit form I see in the devhub, this was a Remora issue.  Now entering 'abc' produces an error message.  But the form didn't check the suggested amount against the max contribution amount.  Added in http://github.com/chenba/zamboni/commit/c716b5c748c894ba32faa439b343c2490ee0e33d
That looks good. I think this fixes bug 605681, or that can be a dupe here.
Duplicate of this bug: 605681
(In reply to comment #4)
> That looks good. I think this fixes bug 605681, or that can be a dupe here.

Yes!  I was looking for that
Whiteboard: [patch]
(Assignee)

Comment 7

8 years ago
Pushed to jbalogh/master: https://github.com/jbalogh/zamboni/commit/ff0718d2983c7b508fdde146e9b374f35493d130
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 8

8 years ago
verified fixed @ https://addons-next.allizom.org/z/en-US/developers/addon/64249/payments

User message now says- "Please enter a suggested amount less than $1000."
Status: RESOLVED → VERIFIED

Comment 9

8 years ago
Created attachment 490992 [details]
post-fix screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.