Print-to-file writes file to program directory

RESOLVED DUPLICATE of bug 360923

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 360923
8 years ago
5 years ago

People

(Reporter: Steve Snyder, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Using Firefox v3.6.2 on a WinXP/SP3 system with 2 printers defined.  I opted to print the current web page, selecting the "Print to file" checkbox.  

When I clicked the Ok button I was shown an "Output file name" dialog box with an edit field into which I could enter the desired filename.  I entered "print-to-file" (no quotes) and clicked Ok again.  I was given no indication of where the file would be written to.

After the operation was complete I had to search for the file.  I found file "print-to-file" (no file extension - what is it, PostScript?) within directory 
"C:\Program Files\Mozilla Firefox".  I got away with this because I have admin rights on this system, but data files should not be written to program directories.  

Would a non-admin user have gotten an error when attempting to write the file?

One more thing: if you click cancel in the "Output file name" dialog, you get a dialog box: "An unknown error occurred while printing." Unknown?
I can confirm this on the 9.1a (2011-9-24) build running on Windows 7 Professional. Would this happen to be a system issue?

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360923
You need to log in before you can comment on or make changes to this bug.