website rejects personas of the proper file format

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
9 years ago
4 years ago

People

(Reporter: crimius, Assigned: jabba)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 

It has been reported in the past that occasionally getpersonas.com has rejected submissions for being the wrong file format when they have been the right format, and simply resubmitting has worked fine and it would go through properly.  This has become a more common occurrence recently, which may have to do with the increased number of submissions.

Reproducible: Couldn't Reproduce
Yep, I've asked for users' images so we can test.
Moving over to IT, this is really hard to test when there are 3 webservers. 

Can someone check all getpersona.com webservers to see if they have enough disk space or /tmp isn't full? Getting 'incorrect file format' errors randomly, which leads me to think image uploads aren't being written to disk.

Munin says disks are reaching 80% full.
Assignee: nobody → server-ops
Severity: normal → critical
Component: getpersonas.com → Server Operations
Product: Websites → mozilla.org
QA Contact: getpersonas-com → mrz
Version: unspecified → other
Created attachment 434644 [details]
test image

Tested with this image and a duplicate for footer. First test failed, unrecognized format message. Second submit worked. 

This confirms that at least one of our webservers is having trouble.
(Assignee)

Updated

9 years ago
Assignee: server-ops → jdow
(Assignee)

Comment 4

9 years ago
Two of the servers in the cluster were missing the ImageMagick package. I installed it and it has been added to the puppet config.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Duplicate of this bug: 554909
Verified, FIXED.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.