copy/paste problem with text not in default font size

VERIFIED FIXED in mozilla0.9.1

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Frank Tang, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-] [QAHP])

(Reporter)

Description

18 years ago
I see this problem when I try to use PR3 to type a song.
reproduce procedure:
1. open composer
2. click "center align"
3. select "formant:Text Size:xx-large"
4. type "this is a book." return and "this is a book." return - two lines of
text get input in the center of the document and display with big size font.
5. select the first line
6. copy the first line by hit control+c or select menu "edit:copy"
7. mouse click below the 2nd line, the cursor will be placed in the center of
the 3rd line
8. paste the text by control+v or select menu "edit:paste"
expect result
the text from the first line copy to the 3rd line
actual result
nothing got copy to the 3rd line. if you keep trying, it will sometimes paste
into it.

If you try drag and drop , sometime the text you drag will disappeare.
(Reporter)

Comment 1

18 years ago
The editing behavior (typing rule ??) is really strange when you have different
font size with center align. I am not sure about other condiction.
(Reporter)

Updated

18 years ago
Summary: copy/paste problem with center align and xx-large → copy/paste problem with text not in default font size
(Reporter)

Comment 2

18 years ago
I find out I can reproduce this regardless the alignment. I can reproduce this
problem even if I skip step 2.
Sorry, I didn't really test on PR3. The build I try is 2000092408 window build.
I try skip 3, but then I can no longer reproduce it. I think there are something
related to the font size.

The HTML source show
<html>
<head>
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
</head>
<body>
<font size="+1">This is a book<br>
This is a book<br>
</font><br>
<font size="+1"><br>
</font><br>
</body>
</html>

It is possible that what I select and copy is
"<font size="+1">This is a book<br>"
(Reporter)

Comment 3

18 years ago
suggest for rtm.
Keywords: rtm

Comment 4

18 years ago
assigning to brade to see if she can come to some resolution, I don't think this 
is an rtm, it can wait till post rtm
Assignee: beppe → brade
Whiteboard: [rtm-]
Target Milestone: --- → Future

Comment 5

18 years ago
accepting bug to keep bugzilla mail daemon happy
Status: NEW → ASSIGNED

Updated

18 years ago
OS: Windows NT → All
Hardware: PC → All
Target Milestone: Future → mozilla1.0

Comment 6

17 years ago
this seems like just another case (overlooked?) where we don't copy the tag
unless you grab the whole container.  I think Joe knows where to fix this so I'm
reassigning to him (should be pretty easy).
Assignee: brade → jfrancis
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Whiteboard: [rtm-] → [rtm-] [QAHP]

Comment 7

17 years ago
can't reproduce, needs to be retested

Comment 8

17 years ago
Resolve this bug as fixed so Sujay can test
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.0 → mozilla0.9.1

Comment 9

17 years ago
verified since I cannot reproduce on 0503 trunk. However I stumbled upon another 
wonderful bug while checking this...
Status: RESOLVED → VERIFIED

Comment 10

16 years ago
I believe that I am seeing this (or a similar) bug in Composer rev. 2001112603

My Steps to reproduce:
1. Launch Composer and create a new document
2. Enter seven lines of text each one being a different size
3. In those lines where the text is either bigger or smaller than the default,
select all of the text except for the first and last characters then copy. 
4. Paste this back into the page or even into another text editor.

Expected behavior:
The pasted text will retain the size parameters and display accordingly.

Actual behavior:
The pasted text will revert to the default size. If the entire line of text is
copied then it will retain the size parameters when pasted. This problem is only
when segments of the line are copied... its as if it is neccessary to copy the
invisible html tags on either end of the line.
Other html editors such as AOLPress will retain font size attributes even if the
whole line isn't copied.

Comment 11

16 years ago
I guess I can't reopen this bug so I opened a new one 112948 - Font sizes are
not retained when pasted
You need to log in before you can comment on or make changes to this bug.