View menu: 'sort by', and 'Messages'-first group: should be radiobuttons

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
trivial
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: akayser, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m18) Gecko/20001004
BuildID:    2000100420

The Sort by and Messenges menu's in the View menu of the messenger
mark the active sort and messages view mode by a checkmark.
This should be a radiobox (as it is a one of the list choice).
For consistent look&feel (certainly in skins which has different looks for radio
and check buttons), this should be fixed.			

Reproducible: Always
Steps to Reproduce:
Open messager, select View menu, select Sort by and
select a sort option.					

Simple patch, should work all environments:
In mailWindowOverlay.xul, id viewSortMenu and for id viewMessengeMenu
change for all menuitem's the type='checkbox' into type='radiobox'.

Comment 1

18 years ago
Reporter is this still a problem in the latest nightlies?
(Reporter)

Comment 2

18 years ago
Yep, still a 'problem'. In the Addressbook and Bookmarks windows the 'Sort'
items are radiobuttons, while in the MailNews windows the Sort and View By items
are checkbuttons. To enhance consistency make all 'sort' and 'view by' items
radiobuttons.

Comment 3

18 years ago
Marking NEW as per reporters comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 60529 has been marked as a duplicate of this bug. ***

Updated

18 years ago
QA Contact: esther → nbaca

Comment 5

18 years ago
*** Bug 60531 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
Marking nsbeta1 to make it more clear that there is one choice and not a number
of choices for the View|Sort and View|Messages menu items.
Keywords: nsbeta1

Comment 7

18 years ago
marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 8

18 years ago
*** Bug 68904 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: nsCatFood

Comment 9

17 years ago
I think this should have keyword access as well - you can't use they keyboard to
navigate to the options, so you can't select them  

ALT+V+Z+5 (font size, radio buttons, fine)

but ALT+V+Y (sort, checkboxes, drops straight out again)

Updated

17 years ago
URL: n.a.
Keywords: nsbeta1- → helpwanted

Comment 10

17 years ago
*** Bug 94394 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
Reassigning to Seth since putterman won't be fixing this (please reassign as 
appropriate). 
Assignee: putterman → sspitzer

Comment 12

17 years ago
Created attachment 52413 [details] [diff] [review]
Radiobuttons in View menu

Comment 13

17 years ago
Created patch using Patch-Maker for View->Sort by and View->Messages.

review?
Keywords: patch

Comment 14

17 years ago
The patch changes type="checkbox" to "radio" and introduces
name="sortby|direction" to account for the different sort criteria (2 active
within 1 menu), and name="viewmessage" to keep the checkboxed menuitems displayed.

Comment 15

17 years ago
This would be great to have. Anyone avail to review the patch?
Keywords: nsbeta1

Updated

17 years ago
Keywords: review

Updated

17 years ago
QA Contact: nbaca → olgam
sorry for the delay, Andreas.

I'll go review and test.

good work Andreas.

I tested the fix, reviewed it, and landed it.
  
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 18

17 years ago
:-)

Comment 19

17 years ago
1. I verified radio buttons on View|'Sort by' for Win 2K and Linux.
   Mac OSX shows radio buttons for View|'Sort by' and 'Messages' - on today's
build, Classic theme - it seems strange.
2. View|Messages: different picture for dif groups. First group (All, Unread,
Threads With Unread, Watched Threads with Unread) shows radio buttons.  Second
group (Threaded, Ignored Threads) shows check marks - we can have 2 check marks
for both menu items selected.  Third group does not show any indication of
selection.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 20

17 years ago
Checked again with build 2001111008 on W2K and 2001111508 on MacOS 9.1

re 1: I am sorry I cannot verify on OS X, no machine available here. But weren't
radiobuttons intended to be there (see bug title)? On OS 9, there are checkboxes
instead of radiobuttoms in the menu.

re 2: The problem is that the menu is a mess by itself (or at least it seems to
me from the outside). I just tried to use the most appropriate buttomtype, and
kept the grouping as it was before the patch. This grouping contradicts the
spec, but the spec in this case does not meet reality, at least for my simple mind.

Here is my rationale:
The first four items form one group, and one and only one of them must be
selected at a time -> radiobox.

"Threaded" and "Ignored Threads" (group 2) are both on/off items, they don't
mutually exclude themselves and therefore I kept them checkmarks as they
originally were.

"Expand" and "Collapse All Threads" (group 3) are commands only, no checkmark is
appropriate since the user can manually expand/collapse any thread anytime and
then a state indication here would become invalid. 

I am aware that the current implementation is not exactly nice, therefore my
suggestion:
re 2: Maybe jglick can shed some light on what this menu should look like, and
open a new bug for that. 
re 1: If problem 1 persists, please change the OS in this bug and state what it
should look like. 

Comment 21

17 years ago
I agree with Andreas.
First group, radio buttons
Second group, checkboxes
Third group, no checkboxes or radio buttons

I will update spec. Can we file a new bug for this?

Also, I don't understand how the "Threaded" item in the Message flyout is 
different from the Thread item in the Sort by flyout. Checking the Threaded menu 
item seems to also enable the Thread sort item. Is this just broken?

[*] All
[ ] Unread  
[ ] Threads with Unread
[ ] Watched Threads with Unread
----------------------------------
[ ] Threaded
[ ] Ignored Threads 
----------------------------------
   Expand All Threads --- *
   Collapse All Threads --- /

Comment 22

17 years ago
jglick: Sort by->Threaded annd Messages->Threaded do exactly the same thing at
the moment, and they also call the same code. 
At the moment turning on threaded view automatically sorts the threads by date.
I guess that the desirable behaviour would be to sort by the criterium in the
sort by-menu (being time, subject, sender, whatsoever), and then keep that sort
order when the threaded view is turned on in Messages->Threaded. This however
would require some work on the backend. But that would, eventually, be a
completely different bug.

Comment 23

17 years ago
Thanks, Jen & Andreas for clarification. I was confused with current
implementation. I am going to log separate bugs:
1.  [RFE]:To have dif indication of selection for menu items in View|Messages:
First group, radio buttons;  Second group, checkboxes; Third group, no
checkboxes or radio buttons.
2.  Another one to log: Messages|Threaded should not do sorting as Sort
by|Threaded does. Currently turning On Threaded view automatically sorts the
threads by date.

Comment 24

17 years ago
Olga, ad 1: I think this concerns only Mac. There are only checkmarks, but no
radiobuttons in the menu. Not sure if Mac uses different XUL or if the
implementation of the XUL-elements is different.

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 25

17 years ago
olga, did you ever get to file the bugs mentioned in comment 23?

Comment 26

17 years ago
Comment 23, #2 is covered in bug 72493.

Comment 27

17 years ago
It seems that we can mark it again 'Fixed' (sorry, for delay).
I add 'first group' after 'Messages' in the Summary of this bug. 
What I mentioned in comment 23(1) is fixed with the patch and reflects discussed
design.
Summary: View menu: 'sort by', and 'Messages': should be radiobuttons → View menu: 'sort by', and 'Messages'-first group: should be radiobuttons

Comment 28

17 years ago
So I take the freedom to marking this fixed (again). 
Olga, will you please verify?
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 29

17 years ago
Verified on recent builds, Win 2K and Linux.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.