Closed Bug 554809 Opened 13 years ago Closed 13 years ago

The drop indicator is not centered when dragging tabs along the tab bar

Categories

(Firefox :: Theme, defect)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox 3.7a4

People

(Reporter: mehmet.sahin, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Hello,

the drop indicator is not centered when dragging tabs along the tab bar.

Thanks and regards
Mehmet

Reproducible: Always

Steps to Reproduce:
1. Open a window with some tabs
2. Rearrange a tab
Actual Results:  
The drop indicator is not centered when dragging tabs along the tab bar.

Expected Results:  
The drop indicator should be centered.
Attached image Screenshot
Screenshot: Minefield compared with Firefox 3.6.2
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
I didn't see this on Windows.
Attached image Screenshot
Doesn't look centered to me. Win7 Pro x64, Minefield nightly build 20100324040325.
I guess it doesn't show up with the windows classic theme then.
Attached image Screenshot #2
Default theme, same version of Minefield, same OS. Removed the StumbleUpon toolbar and the Personal Toolbar. Still not centered.
The directory I was using to test builds must have had some residual files that don't get overwritten when unzipping causing the difference, because after clearing that directory and trying the same build I can now reproduce. Sorry for the confusion.
Regressed between 100316 and 100317. I believe it's a regression from the fix on bug 347930.
Summary: [Mac 10.5.8/Gecko/20100324 Minefield/3.7a4pre] The drop indicator is not centered when dragging tabs along the tab bar → The drop indicator is not centered when dragging tabs along the tab bar
(In reply to comment #7)
> I believe it's a regression from the fix on bug 347930.

Yes, it's from that bug.
Assignee: nobody → dao
Severity: normal → trivial
Status: NEW → ASSIGNED
Component: Tabbed Browser → Theme
QA Contact: tabbed.browser → theme
Attached patch fixSplinter Review
Attachment #434815 - Flags: review?(gavin.sharp)
Attachment #434815 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/e82831cbe8d9
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a4
with this fix when tab bar doesn't overflow you can not drop tab all the way to the left.

when ever we drag over the 3px margin the drag indicator disappear

if you bring back -moz-padding-start: 3px;

then you can fix the drag indicator position by (this is for left to right):
add
+ var ibRect = ind.parentNode.getBoundingClientRect();


replace
var minMargin = scrollRect.left - rect.left;
with
var minMargin = scrollRect.left - rect.left - ibRect.left;

replace twice
newMargin = tabRect.right - rect.left;
with
newMargin = tabRect.right - rect.left - ibRect.left;;
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thanks for letting us know, but can you please file a new bug?
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.