Thunderbird hangs while sending mails with large attachments

RESOLVED INCOMPLETE

Status

Thunderbird
Message Compose Window
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Frank Nestel, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-09-15)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Latest Thunderbird release per yesterday (I am on the wrong machine right now)

I can reproduce this on MAC OSX and Windows XP with the latest Thunderbird release. While sending a mail with an attachment > 11MB (11MB worked) Thunderbird finally hangs. That is, no progress on sending a mail is observed any more. 

The Thunderbird process cannot be killed anymore with MAC OSX 10.5 GUI methods only solution on this platform was hard reboot (i.e. power off) on Windows, Processexplorer is required to kill the process. 

Mail was sent via a slow DSL line, so the crash happens approximately after 30 minutes, which could be a timeout of the target smtp server. However ..

1. .. there are indications, that the same mailing works when MAC OSX mail is used instead of Thunderbird. 
2. .. completely stalling in case of a communication error is not a good behaviour anyway.

Reproducible: Always

Steps to Reproduce:
1. Create a mail with a attachment of 11 MB.
2. Send
3. Wait 30 minutes
Actual Results:  
Then the Thunderbird process hangs, does not respond to any clicks (on either plattform MAC OSX or Win XP) and has to be stopped by "hard" methods like reboot or low level kill

Expected Results:  
Either a sent mail or a error message in case of communication errores with the SMTP server.

Since the process hangs and needs to stopped hard, no talkback information is available.
(Reporter)

Updated

8 years ago
Keywords: hang
Hardware: Other → All

Comment 1

8 years ago
Duplicate of bug 535070?
(Reporter)

Comment 2

8 years ago
Thanks for taking care! Maybe duplicate of bug 535070. It is very similiar to SOME of the issues mentioned there. However it is not IMAP, it has proven to be completely reproducible in SMTP (with or without copying to Sent folder) on several different attachments on MAC OS X 10.5, 10.3 and Windows XP. So for us it feels like "Thunderbird cannot send more than 11 MB attachments". If this is the essence of bug 535070, then we should close this one as duplicate.

Comment 3

8 years ago
bug 535070, which is my bug, is IMO not well defined and not something I plan investing much time in. So perhaps not well suited to be duped to.
Component: General → Message Compose Window
QA Contact: general → message-compose

Comment 4

7 years ago
Frank, What is thunderbird % cpu when this is happening? (using version 3.1) please attach log of  smtp:5,timestamp  per https://wiki.mozilla.org/MailNews:Logging
Whiteboard: closeme 2010-09-15
(Reporter)

Comment 5

7 years ago
Hi Wayne, as far as I remember, there is no exceptional high use of CPU in these circumstances. I can do a test, but right now have a long queue of unanswered stuff in my inbox and it will take me a few days, until I actually want to do that test ..
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.