Java applets flash black during startup (regression)

RESOLVED DUPLICATE of bug 542970

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 542970
8 years ago
8 years ago

People

(Reporter: Colin Bootle, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; InfoPath.2; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

When starting a webpage containing Java applets, the background flashes black, momentarily (e.g. is being painted black once to clear). Before 3.6, initial background was white, which agrees with other browsers.

As our applet fills the entire browser space, this is highly visible!

Reproducible: Always

Steps to Reproduce:
1. ensure Java plugin is available
2. browse to   http://java.sun.com/applets/jdk/1.4/demo/applets/ArcTest/example1.html
3. on a fast machine, you may miss the blink, in which case hit refresh. More obvious on slower machines
Actual Results:  
black background initially, giving a distracting flash

Expected Results:  
white background initially
(Reporter)

Comment 1

8 years ago
The black flash also occurs when navigating away from the page!
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a4pre) Gecko/20100325 Minefield/3.7a4pre

I see this indeed with Firefox 3.6 but it works fine with latest Minefield.
Also latest Lorentz with dom.ipc.plugins.enabled to true doesn't have this problem.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.9.2 Branch

Comment 3

8 years ago
Duplicate of bug 542970?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542970
You need to log in before you can comment on or make changes to this bug.